Performance issue: Webflow not publishing (and loading)

The last 2 hours Webflow is not publishing updates I make to sites, the publish popup in the upper right corner is stuck in the ‘publishing dots’ animation. When I load new sites into the designer, the project is also stuck in ‘Loading project…’ When refreshing the browser the site loads, but slowly. I also sometimes get a ‘whiteout’ of the interface when clicking on objects/buttons.

Just me?

I was stuck on that but logged out to dashboard and went back in and it said it was published.

Hm, the designer is not loading at all with me at the moment.

I’d drop an email to @webflow if you haven’t already.


Yep - having lots of issues here also. The connection / wifi icon at the top right going red and having to reload the page. @webflow @Brando

Problems for me too! Whats going on @webflow @Brando

All the panels seem unresponsive after the first interaction. Seems like Webflow is trying to save that one change and failing, which is breaking the whole app :frowning: In desperate need of a fix.

Strange things!

I duplicated a CMS site, made some changes in a couple of collections, went to save and it wouldn’t allow me.

Next thing, the whole collection went blank with no items…

I went to settings, then back to the Designer, and thankfully the collection had re-instated itself as before…

Scary moment though…

@Christoffer @magicmark @Diarmuid_Sexton @attwoodkt @pgrzyb @StuM

Thanks for posting about this weird performance issue. I ran into a similar issue where a site wouldn’t save but refreshing fixed it after a few seconds. Are you all still seeing the issue?

If so, can you provide screenshots of any errors you are seeing and one with the console open when encountering the errors? This will helps us pin point the root cause of the issue.

​Thanks in advance!

Currently ok here…

1 Like

Started working fine again, maybe half an hour ago @Brando. Ill update you if it starts acting up again!

1 Like

Thanks for the heads up @StuM and @pgrzyb. We will still look into this so we can find out what happened, but I’m glad to hear things are stable for you now.

I’ll report back with more information when I have it. :bowing_man:

Looks like things is now up and running! Publishing is perhaps a bit slow, but close to normal. :slight_smile:

1 Like

I get this issue all the time when I’m trying to edit any content to my site. I can’t do any changes. This white box just appears in my panel… Can it be my browser? I use safari…

@nictur Sorry to hear about the Designer crashing. This may or may not be related to the original post in this thread. To check this, can you please open the console and take a screenshot of the errors you see there?



I have set up an account for the forum to get help.
I’ve been having problems with the designer for 2 hours.

I can’t publish anymore - he just says “Error: Cannot read property id of null” and aborts.
Is this because of the current performance or have I made a mistake?

Best regards

Btw: Im using Chrome.

I’ve also been having problems all throughout the day. Never experienced any problems with Webflow performance before but today it’s barely been usable. Pages just wont load.

Also publishing pages is a nightmare, just keeps hanging.

@Brando I got exactly the screen @nictur posted at least once, so probably related.

Hey people’ where can be found some ofi statement to this issue? Thanks a lot!