Pasting text but keeping the paragraph spacing - seriously time consuming

I need to paste big chunks of text into my webflow site. But when i do, all the formatting is erased. All i need is the paragraph spaces to remain. But I can’t figure out how to do it.

Please could somebody help with this?

thanks…

Copy paste from Google docs is usually pretty consistent.

this doesn’t work for me for whatever reason. Just the same problem. Spaces are removed from the google doc when pasted into the text block on webflow

Do you have them as paragraphs breaks or line breaks?
Line breaks will likely collapse.

Paragraph breaks should properly delimit into <p>'s.
I’ve never had problems.

they were just line breaks

so i just tried it with the

&

in the relevant areas, and it still collapses these once it’s pasted into Webflow

Maybe we are talking about different things

this is what i wrote… < p >. &. < /p >

I’m not sure what you’re describing here exactly, are you generating the HTML from code? If so you’ll have a lot more control.

Copy-paste across apps has always been a challenge particularly with how LFs and CRLFs are handled, and browsers are one of most notable paste-recipient challenges because they have no concept of LFs or CRLFs, and must transpose that into element structures of BR’s, P’s, DIV’s…

What I usually do when I’m dealing with LF-heavy sources is run them through a developer IDE and do regex replacements to repair them to CRLF’s or even double CRLFs. When necessary, code to generate HTML or RTF also works but it’s usually overkill.

Another trick when you paste is to paste with no formatting- CTRL+SHIFT+V on Windows. Depending on the app, it can cause different handling for your line breaks.

I just need these paragraph breaks to remain when I paste into Webflow.

Crazy that it can’t be done


Entirely normal. To you they look like paragraphs because you see white space. To the computer they are probably not paragraphs, more likely you just have some line breaks in there. I cannot tell from a screenshot.

This might help you understand the difference;

The simplest way I’ve found is to paste as plain text, [ctrl+shift+v], I had exactly the same problem and it was really bugging me, and that worked for me.