Streaming live at 10am (PST)

Not able to to upload assets to assets manager


I’ve been working on a Webflow project, and for some bizarre reason, I can not upload assets to the Assets Manager (pngs, jpgs, svgs etc.). I’ve read a couple of pages on the forum regarding this subject, but none has worked for me. I have tried Incognito Mode, but still nothing. I cleared all my extensions and cache, but still nothing, and even tried it on another PC, but it still didn’t work.

My browser: Chrome
Operating System: Windows 10

I need some help urgently. Thank you.

Here is my site Read-Only:

Hi @SiphoY

Thanks for posting about this — it definitely sounds like odd behavior.

Based on the description you provided there could be a couple of things happening here:

  1. It could be a network connection issue. You mentioned you tried on a different machine — have you also tried a different network?
  2. It could be the size of your assets. You are limited to 4mb per image file and 10mb for PDFs, Docs, etc.

If neither of these two are the culprit there could be another issue here. To best troubleshoot this, can you please provide some more information?

What sites are you seeing this issue occur in — only this project or multiple projects?
When did it start occurring?
Can you send me the site Read-Only links please?

Can you please try the following:

Could you also please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!

PS: As a side note on image size, I noticed you have a number of large images in the Asset Manager. I typically recommend keeping all images to 300kb for best page speed performance :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.