Newby issues with list creation

Hello. I am totally new to using any web design tool except I have a fully functional web site that I built with Microsoft Front Page. I have lost use of Front Page and am looking for something to replace it. I got a starting account with Webflow and am trying to learn it. Initially I decided to just try to replicate my existing web, before trying anything fancy. Right away I discovered that it was not as easy as the tutorial made it look. But I struggled along and got 2 partial pages made, both with a Navbar that works. On the second page I decided to use a rich text block for my text. I typed a paragraph and then wanted to add a bulleted list. I looked at the left pane and found a symbol for a bulleted list, clicked it and started typing. It worked just exactly as I expected! After typing each line I hit return and it added a new bulleted item. Great. When done I hit enter twice and the list ended - as expected. Then I typed another paragraph and then tried to add another list. That is where the trouble started. I could not find the icon for a bulleted list anywhere. I finally settled on adding a list from the left pane, but that did work anywhere near as well as the first list. I had to manually add each link item after entering each one. No longer could I start a new list item by hitting enter. And then, as shown in the snip below, I ended up with an empty paragraph above the list. When I select that empty paragraph and hit the delete key - it deletes everything on the page that is above the second list! Fortunately it comes back with the control-Z key, but it makes no sense for the delete key to delete anything that is not selected - what is happening there?
So, so summarize, how do I get back the simple and intuitive method of creating a bulleted list, and what is going on with the delete key? (I’ve seen other inconsistencies, but cannot recall what they were at present.)

Thanks, Russ

Here is my site Read-Only: [LINK][1]

Hi @Russk2txb

Within the Rich Text Block 2 field, double click the blank space where you want the list and it will come up with some options, click the List icon to start a new list (see screenshot).

With regards to the delete button, the Paragraph that shows isn’t technically a paragraph, it’s an empty space so when pressing delete it thinks you are deleting the whole Rich Text field. To ‘delete’ the Paragraph, select the empty line within the Rich Text field so that the cursor is flashing, then press delete. This will remove the empty space ‘paragraph’.