Newbie can't turn off underlining

The entire cell with the LingQ logo at the top has the text underlined, and I can’t seem to find where that was applied to typography… help!

Here is my site Read-Only:

are you talking about this border If I am not wrong

For your link block disable underline here:

Thank you @bro-design that was it. Do you know why the underline button wasn’t activated there? I would assume that it would be in an on position before I hit that X button…

This is an old bug that @webflow still don’t fix😁