Streaming live at 10am (PST)

Need site live today! SSL Error using Godaddy

Not sure what the problem is. Without SSL the site hosting is fine.

Here is Godaddy.

Here is Webflow confirming the DNS settings.

Is it curious that Webflow doesn’t allow me to publish to the naked domain any longer with SSL on?

I’ve used SSL on multiple other sites with no issues. This is the first time I’ve used Godaddy (client’s choice) and now there are issues.

Been browsing the forums and found lots of people with Goddaddy ssl issues, but none of the resolutions have worked for me. Any advice is appreciated as I need to get this site live today.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Has it been solved? I know sometimes this works super fast and sometimes it takes a few hours. Consider contact for speedy and personal help.

Good luck.

Thanks. I did wait 10hrs overnight with no results. Have also emailed too, but it’s the weekend. :confused:

1 Like

@matthewpmunger unfortunately it may just be a waiting game… I’ve had this happen in the past where it took up to 24 hours for it to be all sorted. It seems to be a godaddy thing because it usually doesn’t happen with other registrars (just based on my experience, I don’t have any numbers/metrics)

Hope it gets squared away soon.

1 Like

Hi @matthewpmunger

Just checking you’ve seen this for troubleshooting:

Hi @matthewpmunger it looks like you reverted back to non-SSL DNS records so your site is online from what I see on this end.

Could you please reach out to us on Monday morning at 9am PST via your hosting tab of your site settings and we can walk you through the SSL set up if necessary? Thank you so much for your patience and understanding!

I had seen that article, thanks.

Hey @Waldo I did turn SSL off for yesterday because the client needed the site, but this morning I switch back to SSL and changed the DNS. The new certificate worked immediately.

Not sure what changed or was different than my attempts the other day. All seems good as far as I can tell. Thanks.


So glad to hear that @matthewpmunger! We’re working on updates to our SSL implementation currently, but what likely happened was that Let’s Encrypt received too many simultaneous requests for a certificate resulting in one not being generated when you attempted to generate one the first time. Glad that it went through without any issues on the second attempt.

That makes sense. Thanks.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.