Navlinks in symbols lead to 404 page

Hi everyone.

Im having this issue which is new as the last time I tested the site on preview it didnt happened. Dont know if is a Webflow issue or something at my end.

So basically the link in the navbar even though they point to the correct page they open up as “”.

I have attached the link of the nav link setting plus a page of where does it open instead of “Our company” page in this example.

Here my settings (Pointing to open “Our Company”)

Here the result when I click it:

Any thoughts?

Many thanks,

I am having EXACTLY the same problem across two different sites within the web flow interface despite even restoring the original template, it makes no difference what so ever

Same here. I tried messing around with it for a bit, but wasn’t able to figure out what was going on. I guess there’s a small silver lining in that I am not the only one experiencing this.

Must be a webflow problem.

Anyway not a big issue as you prob can figure it out editing basic html.

Anyways very annoying for the preview… :man_facepalming:t2:

In your 2nd image… the url is

That happens with Preview Mode ??? What happens when you Publish it ?

@cyberdave @Waldo

When I export it works perfectly :slight_smile:

Just tried it out

Hi @Tomas_Alonso, @Revolution, @matthews, @ChayMarie, this behavior is being looked into, as soon as there is information on a fix/solution, I will post an update.

Thanks in advance!

Hi guys, i have submitted two reports through to support. I had purchased two new web flow templates, upon purchase they were fine, made edits and then logged out, upon logging back in several weeks later, none of my navigation bar links work, i get a 404 ‘this page does not exist’- there have been no changes to folder location or URL’s in addition within the designer the links are allocated to the correct pages, so why is it not working across two sites?

I even tried re-installing the original templates but still broken so this must be a problem within web flow because the originals should be working fine. I paid $49 for each template and still the same problem, the links are all broken. Please can someone from webflow sort this problem out???

I have a menu that uses NavLink controls which was working fine a week or so ago. All of the links were going to other pages within my project but today clicking the links in preview mode takes me to folders within the WebFlow site itself (e.g. my Home link goes to and instead of Register going to my Register page it navigates to the dashboard of a user with the name Register). I’ve tried using the designer and re-selecting the pages within my site again to see if that would rewrite the code but it seems to be an issue with a recent release. I can fix this when I export the site but it’s quite confusing to find yourself suddenly in another users dashboard (e.g. If I create a page called Widget, use the designer to create a NavLink to Widget the preview mode will drop me out to Widget’s dashboard).

@Tomas_Alonso, @Revolution, @matthews, @ChayMarie, @Gorbe98, a fix is on the way soon for the links in preview mode. As soon as that is pushed out, I will provide an update to let you know.

Thanks in advance.

Hi @Tomas_Alonso, @Revolution, @matthews, @ChayMarie, @Gorbe98, a fix was just pushed out for the links in preview mode. I would recommend to do a hard refresh in the designer to force a refresh of code in the designer: Scratch Wiki

If any continued issues, let me know, I will be here to help further.

Thanks in advance.


The fix has definitely worked for my site. Everything is working as before now.

Many thanks.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.