"Must Be a Valid Video URL" CMS Error

I’m getting a “must be a valid video url” error no matter what I enter into the video link field of my CMS, YouTube or Vimeo. I’ve seen other closed tickets with the issue before, but no obvious resolution (I’ve tried suggestions). Even taking video links from the “sample” pages as examples – links that work fine in the samples – fails when put into my CMS. Any insights? Notably the error pops up the moment I enter any text at all in the field…

Edited to add: read-only: https://preview.webflow.com/preview/apologica?
Also adding published link - https://apologica.webflow.io/
And screenshot:

Here is my public share link: LINK
(how to access public share link)

hi @Kearlan the best way to get help is to follow the forum post guide that is pinned on top of each section, if you have missed it here they are.

When posting please:

  • Required: Share your project’s Read-Only link AND live site’s Published link
  • The read-only link is a special URL generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?
  • The published link is the webflow.io subdomain where you can view the live site with custom code running. It is important to share this link, as custom code does not run in the Designer.
  • Upload as many screenshots/screencast videos as possible to help others help you faster
  • Add a description and/or post a link to a working example of what you’re trying to achieve
  • Reply to users by tagging using the @ sign followed by their forum username like this: @Kearlan

Try disabling all of your browser plug-ins and especially ad-blockers. I’ve seen them interfere here.

@memetican, I have done that. It’s all disabled. Even used incognito window. Thanks.

I am still having this issue – haven’t been able to update my site because of it. Is this a known bug? Are there workarounds? Thanks.

I was (finally) able to solve this. At the moment, I’m half way around the world. For some reason, using the local network, there was an error with the call to YouTube. Once I logged in with a stateside VPN, everything worked. I’m posting this here both to close the issue, and for the devs/others who may troubleshoot this issue. Thanks.