Streaming live at 10am (PST)

Mailchimp integrated form used to work, now sends no data to MC, but no error msg. either

I have a MailChimp integrated form on my site that has been styled and has worked well for weeks.

Suddenly, it has stopped sending data to MailChimp.

I get no error message on my site (“Oops! There is some error…”)

Even if try and submit the form with an email address that already exists in my MC subscriber database, I do NOT get the ‘Oops!..’ message (I am using this as a debug step to verify that MC is not even SEEING the incoming data.)

I have checked and double-checked every field name, the ‘Action’ code is the correct string from MC, ‘Method’ is set to POST, etc.

AND: If I remove the entire entry from the ‘Action’ field in webflow form settings, I get a Webflow email showing me the new signup. So, WF is working, it’s the POST feature that isn’t.
??

Here’s the SHARE LINK: Webflow - CFAP

The offending form is on the page n75t

THANKS FOR ANY HELP!!
This just stopped submissions to my site! Yikes!

I never could figure out why it broke.
So I deleted the form and rebuilt it from scratch, using the existing Styles.
It works now.
?? Bizarre . . .

It’s happened AGIAN!
Looks like a bug.

Sigh…

I wish there was REAL tech support for Webflow.

IT’S FIXED.

I deleted ALL instances of the form in the ENTIRE site.

I published the site.

I changed to another project in designer

I changed back to my site’s project

I deleted all my assets.

I cleaned up the classes.

I published the site again.

then . . .

I built a new form absolutely from scratch.

And, I dropped in new form-fields for each new field, rather than copy-pasting them

It worked first try.