Streaming live at 10am (PST)

Mail Chimp and Webflow Integration Not Working

I am trying to integrate MailChimp with a homepage form on my website and it doesn’t seem to be working. I followed all the instructions in the article:

If you look on my site homepage now, you will see two forms. The 3-field form on top is set to absolute position, so it doesn’t look like the form fields are in the form wrapper, so I made a second form (2-field form on the bottom) to test it out. I heard that a possible issue is the form fields being in the form wrapper. But it still doesn’t work. I get the “Oops!!” error message for both forms.

I tried adding the S in https and switching between actions POST and GET and still nothing.

Here is the preview link to my site:

Here is the published site:

Let me know if anyone can help. Thanks!

Please publish your site. Custom code does not work in the designer. See Posting Guidelines for the Code Help Category

In future if you want faster replies and more accurate answers, I suggest including all the details listed in the link above before someone has to ask.

Hope to hear from you soon. Thanks!

Ok. I updated my original post with everything that I was able to find in the coding help posting guidelines. I may have posted this inquiry in the wrong category. Let me know if you have any suggestions of another category I could post this in.

Form seems fine to me (I just submitted it).

Can you do a screen recording of you filling in the form and the error message?

Oh. It actually worked for me just now as well. Maybe it didn’t work before because I was in private browsing and had some ad blockers on. Thanks.


I am having the same issue and I receive the oops error. I have published website, but still I get oops error. Anybody can help?


1 Like

I followed Webflow’s official MailChimp tutorial and faced the same “there was a problem” error screen issue over and over.

My solution was stupid and straightforward: I stopped entering generic email “”, which MailChimp appears to reject, and instead used my personal email. It worked right away.