Streaming live at 10am (PST)

Integration with mail chimp and webflow form not working

Hello Intelligent Webflow users . . .
My integration with webflow and mailchimp is not working. I am redirected to Mailchimps form (which i dont want to use) after submitting. ref: www.ambermobility.com/stayinloop.

how to resolve the issue.

Note: I dont have this issue in www.888-cda.webflow.io.

If the form action is set, then the form will post to that page instead of using Webflow’s default form handling.

yes, form action is set.
https://preview.webflow.com/preview/amber-888cda?preview=e1fd60ea04b415c1eab333b240ce90f1

But i dont understand how it is working for http://amber-888cda.webflow.io/stayinloop and not for www.ambermobility/stayinloop.?

Try changing the target’s protocol from http:// to https:// (just add an “s”)

As well as setting the METHOD to GET instead.

1 Like

" https://33one.us13.list-manage.com/subscribe/… "
can you please elaborate?

I have set method =Get

Apparently, the form action for both sites is also different.

i changed form action : https://33one.us13.list-manage.com/subscribe/stayinloop

methode=Get

after submitting i got this : https://33one.us13.list-manage.com/subscribe/
404 error page

Also, error while submiting form from http://amber-888cda.webflow.io/stayinloop.

Is this something related to Redirect - https://help.webflow.com/article/how-to-redirect-old-urls-to-new-pages-in-your-webflow-site-301-redirects

How are the form action different for both the hostings?

@samliew . . .thanks

I decided to post this here since it is a similar issue.

I am trying to integrate MailChimp with a homepage form on my website and it doesn’t seem to be working. I followed all the instructions in the article: https://help.webflow.com/article/how-to-integrate-webflow-with-mailchimp

If you look on my site homepage now, you will see two forms. The 3-field form on top is set to absolute position, so it doesn’t look like the form fields are in the form wrapper, so I made a second form (2-field form on the bottom) to test it out. I heard that a possible issue is the fields being in the form wrapper. But it still doesn’t work. I get the “Oops!!” error message.

I tried adding the S in https and switching between actions POST and GET and still nothing.

Here is the preview link to my site: imagehttps://preview.webflow.com/preview/gsmarketmedia?preview=d045d4faaabbe45075fe41440fb78f51

Let me know if anyone here can help. Thanks!

Sharing for anyone who comes across this thread and cannot find a solution–

I followed Webflow’s official MailChimp tutorial and faced the same “there was a problem” error screen issue over and over.

My solution was stupid and straightforward: I stopped entering generic email “test@test.com”, which MailChimp appears to reject, and instead used my personal email. It worked right away.

2 Likes

Thanks for that!! Thought I was going crazy