Localization not working

Hi, I have added a new language and when I Publish the website, impossible to switch the language in the menu. The URL is correct but it keeps on reloading on the /en page and not redirecting to the /fr.
Can someone help ? :smile:

Link: MyQM - A.I. Powered Automatic QA and Conversation Insights

Hey there @kevin_Tillier — Joshua here from Webflow. That doesn’t sound quite right. Could you please submit a ticket at https://support.webflow.com/topics/designer and DM me your ticket number. I can make sure it gets to the right agents as soon as possible.


Hello, @kevin_Tillier, Ellen here from Webflow Support :wave:

While waiting for your support ticket to investigate your project, I had a look at your DNS for your domain, and it looks like the CNAME record currently resolving for your custom domain could be the culprit here, causing conflict with the locales list. I also noticed you are missing one of the A records used.

Can you please make the following updates to your DNS settings for your custom domain?

Remove this record:

Add these record:

Record 1:

  • Type: A
  • Name: @
  • Value:

Record 2:

Let me know how you go! :smiley:

Hi, I’ve created a locale and the home page domain.com/fr is working fine but the links to other pages like domain.com/fr/about-us returns a Page Not Found… Am I missing something?

He Elen,
Can I ask yoo to help me? All my localized pages return 404 error page. I wrote about it here but got no answer for now.
I will copy my message here.

Hi there,

I moved from Linguana to native Webflow localization. I translated all content, payed for add-on. But when I publish localized version, I see only 404 page. I can’t understad why if its my fault or somwthing on Webflow side.

Would appreciate any help.

Example of the localized page https://www.leadlion.ca/en
Read-only link: Webflow - LeadLion


You need to enable publishing for your locale first, under settings.
To do that, your site will need to be on a hosting plan, with a localization addon.

For others, even after you buy that hosting/localization plan, you need to go back here and then enable that locale for publishing. If you had the designer open during the plan purchase, you’ll have to reload it.

1 Like

Thank you very much! Now it’s working!

Thank you very much! Now it’s working!

1 Like

Sorry, can I ask for your help again? I try to install locale switchet. When it is in the separate section it works perfectly. But when I move it in the navbar, it doesnt work. I don’t understand why. Can you have a look please?



Hi Olivka, the locale switcher seems to be going through a lot of design work, I’m having various issues with it as well.

But in your case with the dropdown approach, it’s working but that the dropdown is getting cut off. Change your container default class in your nav so that it allows overflow.

I tried you approach and now it works on descktop version, thank you for the advice! But at tablet and mobile when I open a hamburger menu all page becomes red. I understand it means a mistake but see no mistakes. Where an I wrong again? :slightly_frowning_face:

In general Webflow’s navs are difficult to debug, because they have a specific expected CSS setup and some javascript running behind the scenes.

What I can recommend is, on a hidden style guide page, do a quick rebuild of your nav with no styling, and include your locale switcher. Get it working with zero style or layout changes. Then start applying your style and layout changes on top of that working base.

If it’s already broken before you add any styling, then it means the locale switcher probably is not yet ready for use in the way you’re trying to use it. At that point I’d check with support or use a non-dropdown approach.

If you really want to learn how to debug these problems, get very familiar with Chrome devtools, it will let you identify the CSS problems you’re having and then you can trace them back to your designer setup to identify and correct the problem.

Thank you for your answer. The problem was resolved, but I dont know how because other person built language swither outside the nabar. And then, few days ago I build again in the navabar and that works