Localization is Not Auto Routing

I have implemented localization on my website, but when I change the browser’s language to (and only) ‘en-AU,’ the website does not route to the correct localized page as expected.

For instance:

  1. Set your browser’s language to ‘en-AU.’
  2. Visit https://sumhiit.webflow.io/
  3. It should automatically route to SUMHIIT Fitness - 35-Minute HIIT Workouts for Maximum Results, but it doesn’t.

CleanShot 2023-11-17 at 18.13.57

Is anyone else experience this issue of the new localization feature not working as expected?

If you only have 1 locale on your website, it will be your primary locale by default. Your primary locale does not route to a different url with /en-au

Only locales added in addition to your primary locale will do this.

There are 3, essentially. The default space, and two others. Routing is not working.

CleanShot 2023-11-18 at 06.48.45

Did you get this to work? I’ve got a German version and I’ve set Chrome language to German, set German as prioritized language and I’m using a VPN set to Germany… :man_shrugging:

What localization plan are you using? If it is the Basic plan, automatic localization routing will not work. The Basic plan only lets you have multiple languages that users can select from using a locale selector element. The Advanced plan is required for users to automatically be routed to their locale based on location and language settings.

Which localization plan are you using? The above reply may apply to your situation as well.

Hi there, juste jumping into this thread because of a problem I noticed.

When the automatic routing activated, some users cannot switch to another language.

My client have EN and DE on their website and some cannot access the EN version of the website because of these parameters…

1 Like

same problem for me. This problem seems to occur only on the homepage, so if you go to another page, it’s possible to change language. I’ve created a support ticket.

3 Likes

Hey @sebastienwozny, did you have any news about this ? Have the same problem for a client, on the homepage the main langage is FR (Main langage) and cause my browser default langage is EN i can’t access the main page, but fine on other page as you mention…

I’ve disabled the auto-routing and made my own in javascript since it’s seems not to be a priority for Webflow. :sweat_smile:

Nothing is a priority for Webflow except to make as much money as possible while doing as little as possible to offer a working product.