Localization not appearing

Hi webflow!
I have paid for localization, but somehow it is not appearing anywhere.
When going to settings, there is no option to add a locale, neither when in designer.

I remember having seen it a couple of weeks ago when you launched it. What happened?

I just launched my redesign and I’d love to work on my translations.

Any help?


Click the gear at the bottom left to get to your site settings in the designer.
You’ll find localization there.

1 Like