Localization Leading to Home Page

Link - Webflow - Myhotelshop

Localization is leading to the Home page regardless of the page you switch it from.

What is happening:
Products & Pricing | Myhotelshophttps://myhotelshop.webflow.io/de

What should happen:
Products & Pricing | Myhotelshophttps://myhotelshop.webflow.io/de/preise

Unless this is the expected behaviour?
Is anyone else experiencing this ?

1 Like

I have the same issue. Can’t find the way to make it work. Have you solved it?

Hey @paco
Im not sure if this fixes for some reason or in the background webflow fixed it. But if you are still seeing an issue - try putting the language switcher on a page that isnt the home page and is not in a component, then testing to see if it works.
It worked for me and then I put it back in the component (nav bar) and it continued to work …

The only place I have the switcher is a CMS item page. Still not working :frowning:


I have the same problem here. There seems to be a bug in the localization. It works on some sites and not on others. Maybe a Webflow supporter can take a look at it.




I contacted Webflow Support yesterday and they confirmed that it was a bug in the localization programming. They have since fixed the error and everything is working as expected.


1 Like

I honestly wouldn’t recommend using localization at this moment. I lost all of my translations, I don’t know if it’s because of the update, but it still feels unstable and unpredictable.

@JeffreyL @paco I have solved this issue by setting the location Link Block settings from Subdirectory to Page. However I have still issues with the localization that when I switch from a page it redirects back to the default /en subdirectory…

Weird, it runs here just fine. (2 locales) What is your set-up? You used the locale-list? Do you use the locale list in a navigation bar element or as symbol?