Streaming live at 10am (PST)

Issue with my API for Google maps

See the link below:
http://quick.as/YdwvfJnjg

Website: www.schuur4.nl

Thanks for having a look at it!

Hi @Koen

Thank you so much for posting about this.

By the looks of the error seen in the console, the API isn’t currently active

Can you please try to generate a new API key and ensure all the steps laid out here are followed: https://university.webflow.com/article/map

​Thanks in advance, and I’m standing by for your reply to see if this fixes the issue.

Hi Brando, thanks for having a look at this.
I followed the course already before. After making another API its still not working.

Designer link:
https://preview.webflow.com/preview/rojos?preview=12749930a266e1d4551b274370d7909f

Thanks for trying that again @Koen

I’ll report this to the team to investigate it further!

Koen,

are you using the right API I ran into this myself not too long ago. Which API are you using? The embed one doesn’t work. I think it’s the javascript one that needs to be used. Correct me if I’m wrong @Brando

If you use the other one. It won’t work with webflow

Yes that is correct @jbleroux

The key must be generated here: https://developers.google.com/maps/documentation/javascript/get-api-key

Strange, in the link from out of the designer i get this:

But in de link from @jbleroux its working!!!

Thank you all for helping me!!

KLoen

1 Like

Thanks for letting me know it’s working now. :slight_smile:

Let me know if you see any other odd behavior!

I get the same error when tryign to access the link given by webflow.
But using the link from Brando works.

Hi @rowan

Thanks for letting me know.

I found the issue and reported it to the team. It looks like the link in the project settings is appended with ?authuser=1. If you remove this last bit in the URL, press enter, and then try to generate an API key, it should work as expected.

(upload://57SIizwea7sh9LqHpGSrI0hkzSd.png)

1 Like

Hi @rowan, @Koen, @jbleroux

We pushed a fix for this. The link in the project settings should work as expected now :+1:

Let me know if you see any other strange behavior around this!

2 Likes

I’ve hit this issue too while building my site: Here

There are no restrictions to my API key, everything is enabled, integrations added to the setting in Webflow. Created a new key also. Still says it’s not authorized.

kbarrett - I believe your query needs a place id - the “q=” at the end
https://www.google.com/maps/embed/v1/place?key=AIzaSyDV1HY3i6YbUwMXvIXpuuVuGssr3lMDQws%20%20%20%20&q=

Here’s one for Apple store in Naples FL
ChIJgb11u0Ee24gRGtZ9_kwlDJ8

Thanks @orgreeno. I tried that, but it didn’t solve the authorization error.

Not 100% sure if it’s related

  • but I received a similar (extremely generic) message.

In reading the docs… I discovered a limit of 10 API’s.

I had hit this limit. There was an option to request an increase.

I contacted Google to request an increase

  • Google increased the limit to 100
  • This immediately fixed the issue and I haven’t seen it come back.

Again… not sure if this if the same issue. But that’s how I fixed it.

Thanks @Revolution. I only have 3 APIs. I even deleted ones that I don’t need but the maps still show the same error.

Which APIs do you have enabled? Embed API?

I’ve tried using an API key that I created months ago for another Webflow site I did with no restrictions and it works fine. So it seems like whatever API keys I create recently are not going through Webflow for some reason.

Not key, but Google Maps Embed API.

Do you see this in your console?