Streaming live at 10am (PST)

Google Maps API not working

The API is activated, but Google keeps throwing the “API not activated error”.

1 Like

Hi @Cricitem please follow these steps and pay close attention to Step 2 in this guide:

Once you’ve updated/activated your API and re-published your site, can you please let me know if that resolves the issue on your end? Thanks in advance! :bow:

1 Like

That is really weird. I’ve got another project I did this for and I didn’t have to do all of that. I just enabled it (this one was showing as enabled already), and I was good to go. This time I had to enable it a second time by going through all of that nonsense.

There really was a time when computers and the internet “just worked”. /-:

Thanks for the help.

1 Like

Thanks for letting me know that resolved the issue! :bow:

1 Like

I have tried several times to do this and I still get the Whoops something went wrong screen. The directional map on my website is quite important so if anyone can add another clue to success please let me know. I think the project selection may be an issue, I did enable on both screens.

@fordsvilleweb can you please follow these steps and pay close attention to Step 2 in this guide:

If you’re having any trouble, please send me an email at and let me know which site you’re having trouble updating, thanks in advance! :bow:

Hi there,
I am struggling with the same issue just now. I have followed all the steps in the guide.

The result is:
The native Webflow Map element shows the correct map on the published site.
However, the HTML embedded iframe as described by @alexn using the same API key shows the error “The Google Maps API server rejected your request. This service requires an API key.”

Here are both elements live:

Btw, when I restrict the usage of the API key to, even the native Webflow Map stops working, in spite of the domain having been verified in Google.

Am I doing anything wrong here?

Thank you! :slight_smile:

Just in case it helps someone having the same trouble in the future…:

I wasn’t aware that to be able to use Google Maps embed, also the “Google Maps Embed API” must be enabled in the Google API Manager (not just the “Google Maps Javascript API”). It is hidden and accessible via the “More…” button in the API list.

Then even the dynamic GM embed works as expected :slight_smile:

1 Like

Well, to my surprise, I think it is working. I didn’t get the “Whoops” error today and on each page the map looks good. Thanks so much. The website was

Really do appreciate how much help one can get in this Forum.

Thanks so much Waldo!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.