Importing csv and mapping image fields

Hi there. I am having trouble understanding how to handle images for mapping from my csv file to a cms collection.

I have set up my csv file in a google sheet, and inputed the names of my jpgs for both a main image and a thumbnail image.

In my collection I have created an image field for my thumbnail image; and one for my main image.

when I try to map to them, I see a message of “the imported data isn’t compatible with this field”

I also tried uploading the images to my assets; this didn’t seem to make any difference.

I have looked at these tutorials and I am not getting what I am doing wrong; or what I need to do. (all of the videos in this collection)

here is a screenshot of what I’m seeing when trying to import my csv file:
here is what my csv file looks like:


Here is my public share link: LINK
(how to access public share link)


I figured this out –

  • i had first uploaded all my images to my assets and then used relative paths to them and this didn’t work.
  • i then tried uploading them to my google drive and using the file path – that didn’t work, either but that could have been because of sharing permissions.
    *** I then created an AWS account and created an S3 bucket and stored my images there, and referenced those paths from my csv file – and that worked.**
1 Like

Glad you sorted it.

Yes, you need to make sure the files can be accessed by the CMS so an S3 bucket is an easy (easier) way to go.

I have been having the same issue. I first used the path to the images where they currently reside, on a website in their respective folders. That didn’t work, so I used your solution and downloaded them all to an S3 bucket… made them all public, and copied a few of the links to a browser to make sure they worked. Then I modified the csv file to use the path to the S3 bucket for each image. And it still won’t mapped. The image field is still greed out? Ive spent hours on trying to figure this out. My “webflow expert” friend tells me it isn’t possible to import images from a csv import, but I KNOW it is… especially since you say you did it. HELP

Hi Neil –
make sure that your images on your s3 bucket have the correct permissions to be public (read/write i think)…

Thanks for the quick reply. I just double checked and all the images are public, with red and write access. Im going nuts here.

I could try a dummy spreadsheet and see what that url has to be to unlock the image field I guess… but it is strange. I cant see why it wouldn’t have worked just using the URL of the images folder on the current website… which is obviously also public.

I managed to get it to work. there was an error in one of the image file names. It had a space and it was breaking the import! Should have thought of that first. Thanks for the help.

I just attempted this using dropbox (public folder) and had no luck. Has anyone had success using Dropbox for importing image fields?

When the image files are formatted correctly, everything works as expected.

I’ve been having issues importing images also. Was using Jotform to collect data, integrated with Google sheets for processing/review purposes. Images weren’t importing due to URL formatting issues somewhere along the way. I believe the images being uploaded had spaces in the file names that stuck with the image through the whole process.

Would be nice to run an import, have items that ARE formatted correctly to be successful and an error report for items that are not properly formatted.

OMG, I needed this. Thank you for posting with such detail.

Yup, the problem is with the spaces!

Hi, same problem here. Tried the S3 bucket on AWS but same s***, can’t import thoose images.