Google fonts / GDPR / How to load "Open Sans" locally?

Hey guys,

the EU privacy protection recommend that companies should install Google Fonts at a local server. For most fonts it’s not a problem as you can just upload as custom font to the server.

BUT: Certain fonts - like Open Sans - seem to be “pre-installed” by webflow. We tried to upload Open Sans (and all variants) as custom fonts - but webflow is still connecting to the Google API server.

<script type="text/javascript">
WebFont.load({
    google: {
        families: ["Open Sans:300,300italic,400,400italic,600,600italic,700,700italic,800,800italic"]
    }    

How can we prevent this to comply with the legal requirements? How can we make sure that Google Fonts is loaded locally?

Any ideas?

Thanks a lot!

Michael

1 Like

I dont know if this works, but here’s an idea:

Rename your local font files to something else (for example “Open Sans Local”) and then try to upload them to Webflow again.
Maybe Webflow will not recognize it as Open Sans when the file has a different name.

Hi, thanks for the idea :wink:

Bur if Webflow would not recognize Open Sans as Open Sans - and Open Sans is automatically loaded via the Google API - that won’t stop the API call … will it?

I think it actually does work.
As far as I can see Webflow doesn’t load ALL preinstalled fonts that Webflow provides. It only loads the fonts you use in your project.

If you upload your local (renamed) Open Sans font you will see it in the fonts-dropdown in the Webflow Designer as a separate font besides the preinstalled Open Sans.
As long as you don’t use the preinstalled Open Sans on any element on your whole website, it should not call the Google API.

Got the same issue, Michael…seems to concern one of my websites…all fonts are hosted locally, still by inspecting the source code, webflow automatically calls the Google API and thereby makes the site incompliant with GDPR…how can I get rid of that?
rel=“stylesheet” type=“text/css”/>WebFont.load({ google: { families: [“Montserrat:100,100italic,200,200italic,300,300italic,400,400italic,500,500italic,600,600italic,700,700italic,800,800italic,900,900italic”,“Exo:100,100italic,200,200italic,300,300italic,400,400italic,500,500italic,600,600italic,700,700italic,800,800italic,900,900italic”] }});

also see my post Uploading a Google Font as a Custom Font (GDPR)

does uploading a custom font actually make it gdpr compliant?

Hi Bob,
all Google Fonts are uploaded and hosted locally already…however, Google API is called via a script / CSS right at the beginning of the website’s source code and I have no means to change that in the settings…still, I want to get rid of it due to GDPR compliance.

Here’s the solution (as I wrote twice in this thread already :wink: ):

  1. Rename your local font files to something else than the original file name
  2. Upload the font files to Webflow
  3. Apply the local font to all your font-elements in the style-panel
  4. Delete EVERY SINGLE element AND class (even your unused classes) that still use the Open Sans from Google.
  5. Publish your site

Now your site will not call the Google API anymore.

If you need proof
Here’s a test site where I use the local open sans font. You can see in the developer mode that it doesn’t call the Google API.
https://webflow-local-font.webflow.io/