Gclid query param being auto redirected by webflow

This isn’t site specific, and can be replicated on any webflow site. For demonstration purposes, I will pick one here from the demo site: Best Demo Websites | Free Examples & Designs - Webflow

Example: https://moving-gradient-background-kl.webflow.io

If I wanted to add a query parameter, it works fine https://moving-gradient-background-kl.webflow.io/?param=123 and I can see it in the address bar the query param. Great!

BUT if that param is gclid, it automatically gets redirected back to the home page, and it seems to ONLY be with gclid.

https://moving-gradient-background-kl.webflow.io/?gclid=123 => redirects to https://moving-gradient-background-kl.webflow.io/

I cannot find any settings to disable this and allow it through.

Why does webflow block the gclid parameter? Is webflow perhaps using their own gclid values, so is purposefully blocking all sites that pass it? Is there settings anywhere to disable this behaviour?

Hi @J_H,

I experienced the same problem as you, the following is my story I hope it helps you and others until this thread gets an official response.

It would appear if Google Analytics is enabled via the webflow UI:

  • Visits to your webflow page containing gclid will be 307 redirected to self with gclid stripped

When I clicked ‘remove tracking’ in the Google Analytics section of my webflow site and instead enabled Google Analytics via Google Tag Manager, the redirecting no longer occured.

Obviously shifting analytics to GTM away from webflow UI might be a big task for you.
So i’d encourage you first check whether a cookie for _gclid is being set against your domain by webflow.

I think they may be setting this as part of the 307 redirect in this instance so it may be accessible to you if you read that cookie via javascript