Streaming live at 10am (PST)

Form submit doesn't work any more

Hey, I’m having trouble with one of my forms. Not sure if this is the right category but I’ll give it a go.

The form submit worked fine in the beginning. then it stopped working and I have no idea what caused it, I didnt work much on the site in the meantime (just some design things). When I click the submit button now, all it does is reload the site but the information isnt submitted. No error message either.

I have replaced the submit button and gave my form an ID but nothing changed.

Can someone help?

Hi @mareikeschu,
you might want to try switch the action’s method to “POST” instead of “GET” if you’re using the default Webflow action (which seems to be the case).

Hey @anthonysalamin,

thanks for your advice! I switched the action method to POST and tried again. I got a 405 Not Allowed now :frowning:

anything else I could try?

Yes, try to remove the jQuery dependency at your page level custom code section, you do not need it since Webflow already implement id natively. Referencing it twice might indeed cause issue in the form submission.

Hope that helps.

1 Like

That worked! Awesome, thanks so much for your help!

1 Like