Streaming live at 10am (PST)

Fonts showing on Desktop browser but not on Mobile


I’m having trouble seeing fonts being updated on my mobile browsers. They’re showing up default sans serif.

But when I view the site from my desktop browsers, they look fine.

What am I doing wrong?

Thanks in advance! :slightly_smiling:

Hi @mcelso

Can you please post your read-only link?

Also, are you using a Google font or did you upload your own?

Hi @PixelGeek!

I now changed it to read-only:

And I’m using TypeKit.

Thanks! :slight_smile:

Hi, Just wanted to follow up on any updates on this.

Thanks in advance!

Hi @mcelso, thanks for the read-only link. If you have not already, could you please check the Typekit troubleshooting instructions here:

One thing I noticed in the design, the h1 title has no class at all assigned, and the paragraph text is styled with Proximal nova with 300 font weight is selected, but only 400 and 600 font weight has been enabled from Typekit.

I would check the troubleshooting steps above in the link, republish the typekits and then check the font weights are correct for what has been published from Typekit.

Let me know if I can be of further help.

Hi @cyberdave — thanks for suggesting all the good troubleshooting tips!

I gave the h1 (and all other header classes) a name and selected 400 for Proxima Nova. Unfortunately, Adelle still would not display on the mobile browser. ;( odd…

So, I tried Google fonts, instead. And their fonts seem to show up with no problem. I remember having some trouble using TypeKit on other WebFlow projects, too. Google fonts, though, worked for me.

Thanks again! :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.