Streaming live at 10am (PST)

Editor Unresponsive error

A client just reached out to us about an “Editor Unresponsive” error they’re getting whenever they try to edit any page.

Can someone help. They are using Google Chrome

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi, @Daniel_Parker!

Ben here with the Webflow Customer Support Team!

Which project is your client having issues with? Can you share the read-only link with me so I can jump in and investigate?

Also, can you please test the following on your end:

(1) Have your clients try to reproduce the error while being logged into the Editor using Incognito mode with browser extensions turned off:

(2) If the problem persists, can you have them take a screenshot of their Console and post it here for me:

(3) Could you please let me know what browser version your client is using by sending me their information from this page

Thanks in advance for helping us with these troubleshooting steps. Because Webflow is a browser-based web application, there are many local environment variables that can cause issues like this, and we want to rule those out first. We really appreciate you taking these additional steps, as it helps our engineers with their investigation.

Howdy – One of my clients is having the same “Editor Unresponsive” issue. Here’s the read only link if you could investigate:


@rileyrichter Also, they just tried Incognito mode in Google Chrome without extensions and are still getting the “The Editor is unresponsive” message – just so you know!

Hi Ben. Here is the link

Image of error. The editor is also very very slow. It takes up to a minute to load each page when they are clicking through.
When they make an edit. This error comes up and kicks them out of the editor. But when they log back in the changes they were trying to make are ok and have been changed. It just kicks them out each time.

The errors also happen to me on my browser. It was fine last week.

Sorry I’ve replied to you on my other account. I have 2 accounts for some reason.
Here is image of errors

Daniel Parker

@rileyrichter My client reported that this issue is only happening when trying to update photos, if that’s of any use. Thanks!

Same error here.

Yep same only with photos. But editor is still extremely slow

I have a client having the same issues with their editor. Seems to be a widespread issue.

I need this issue resolving ASAP. I chose Webflow for my client on the promise that the editor is seamless. My clients are not happy :slightly_frowning_face:

Same issues as above. Subscribing.

I’m having the same error as above … Was working fine earlier today, but in the past 2 hours, it’s been giving the same error message! After logging in, the page will flash up for a moment, but then go blank … then after a bit, the following error modal pops up:

Here is the share link:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.