Streaming live at 10am (PST)

Editor bug during demo

Hi guys, just thought I’d post this here as I got a pretty bad time today…

So during a presentation with a potential client, I’m asked if I can demo how the Editor works. “Of course” I said, just before having the most awkward 15min since I set my mother in law’s chimney on fire (true story)…

Quick summary of what happened:

  • I logged in on the designer
  • opened the editor from there
  • was presented with a blank page (but with Editor bar showing properly at the bottom)

(minute of silence in the audience… I’m getting nervous…)

Now I do the following:

  • restart Chrome
  • log in on the designer
  • open the editor from there
  • get the page with the password option (the site is password protected…)


But then:

  • I start entering my password
  • the password box disappears

(minute of silence again… very awkward moment…)

I redid the above a couple times for the same result.
Finally, I then go back into the site settings, remove the password protection, and it WORKED.

All good in the end but my chances to get the gig are very diminished… This also made it very hard to sell the $20 hosting to get the Editor, compared to the $5 hosting the guys already had with OVH.

Oh wait, best of it, when I tried this again 2 hours later (with password back on) all worked fine.

I’ve made a very big commitment going with Webflow, but the dramatic amount of bugs we’ve seen in the past weeks is hugely concerning. This is a B2B platform, and businesses are depending on it. Please make sure it works!


1 Like

Hi @PasolInteractive Thanks for posting this, this definitely sounds like odd behavior and I want to get this resolved immediately to make sure this does not happen again. We’re looking into this issue right now!

Do you have any custom code in your site by chance?

What site are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only link please?

Please send me screenshots of the behavior you’re describing.

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off:
(2) If the problem persists, please take a screenshot of your Console and send it to me:

Could you please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!

Hey @Waldo

Browser is Chrome 56 on Mac OS X 10.
Only custom code I got is Google stuff:

  • Google Fonts
  • Google Tag Manager
  • Google Analytics JS

I’ve not been able to reproduce the bug…

I’ve PMed you the read-only and browser links.


Hey @Pasint!

Super sorry for the delay and sorry to hear about this bug to appear during presentation.

We’re currently working on this case to make sure it won’t happen again. We’ll get back to you as soon as we have a solid fix ready :slight_smile:


Hi @Pasint we’ve pushed a fix for this issue so you should not run into it any longer. Do you mind testing on your end to make sure everything is working as expected?

Thanks in advance!

Hi @Waldo, @bart,

Thanks for following up on this.
No problems with the delay, I didn’t have to do a similar presentation, so wasn’t impacted by this bug again (I didn’t manage to reproduce it before, so not sure what happened anyway.

I checked again today on Chrome, and things ran smoothly for me.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.