Streaming live at 10am (PST)

Fixed: Editor loads for a moment and then disappears

first of all I want to let you guys know that we’ve been fans of Webflow in the office since we started using it for over two years ago.

Wednesday something happened that was a bit troubling. The Editor stopped working for one of our client accounts(Business Hosting). It was really strange, and as far as we know, only one of our clients are affected. We tested the Editor and got the same error, and was not able to use the Editor either. Our client had a deadline on Friday, so this was not good at all…

We reported the error to Webflow on Thursday, and got a message from them saying that they knew about the error and that their engineers where on the case. Since then we haven’t heard back from Webflow, and our client is not happy…

So our question to Webflow is: What can we expect from Webflow when stuff like this happens? Our clients are paying for CMS hosting and expect it to work. We as agency are stuck in the middle and held responsible.

One more thing. Please fix this bug so we can continue our work.


Screen shot of error and console.

Here is our public share link:

Hi @biodust firstly I want to apologize for the lack of follow up communication, that’s unacceptable and we won’t let that happen again. Please know that we’re actively working on a fix and you will hear an update back from us by EOD tomorrow PST.

If ever you’re left waiting on a fix, please let me know immediately, I’m here to help as much as possible. We’ll get the issue resolved and I’ll do everything in my power to help make sure things are made right and get your client working again.

Thank you so much for your patience and understanding, I know how frustrating it can be and will make sure this issue to get resolved ASAP.



This was caused by an error in your custom code, and is NOT Webflow’s fault.

This is the code you added to your site

if ($('#minicart' > div.field-item:contains("0")) {

It should be

if ( $('#minicart > div.field-item:contains("0")') ) {

You are missing ') in your code, and the single quote ' was terminated prematurely after #minicart

CC @waldo @cyberdave

Disclaimer: I am not a staff of Webflow, and the opinions expressed above are my own and do not necessarily represent the views of the Webflow team. I disclaim all and any responsibility or liability in respect of information detailed or omitted (or the consequences thereof) from this post.

1 Like

Moved out of bugs category.

@samliew this is not correct, and the bug still remains after change of code. We removed a lot of the javascript when we testet the error ourselves, but it didn’t fix the issue. We have not changed the custom code for a couple of weeks either, so the sudden error is not caused by new code from our side.

In the email from Webflow they admitted having an issue, so it’s a know bug from their side:
"This is a known bug that our engineers are currently looking into"
Please don’t mark the post as solved before we have tested and approved it.

Thanks @Waldo og @cyberdave for looking into this. We need to get this fixed today.

The JavaScript custom code is still broken on the published site. Did you really change it to what I suggested?

Couldn’t you just simply fix your site to see if that’s really the issue? I even went the extra mile to provide you with the corrected code. Do note that ANY invalid custom code will break the site, you may or may not have encountered this issue earlier, or someone else could have changed the code for you (if you are sharing accounts).

Yes, we have tried change the code like you suggested, and even removed the code. Error still remains.

I really appreciate you trying to help, but error with Editor is not effected by these changes. Webflow also said they knew about the error, even before we told them the url of the site

I’m not trying to be difficult. I just want to the Editor to work, so our client becomes happy again.

Thanks again.

1 Like

Hi @Waldo and @cyberdave,
it looks like only the index page is affected by the error. When I navigate away from the home page, the error message disappears and “Editor” toolbar remains fixed. For now this is a temporary solution for editing content in collections and on sub pages.

Hi @biodust, Sorry for the lack of info, we try to update customers on issue resolution as quickly as possible, however this issue is still open.

One thing that triggers the error with the editor is if there are any emtpy collection lists on the page.

As a workaround, you could duplicate the page, then delete the emtpy collection lists and republish the site.

As soon as there is a fix pushed out, I will let you know immediately.

Thanks in advance

Awesome @cyberdave. The index page now works. The empty collection is in use, just not all the time.
Looking forward to the fix.

Thanks for looking into this.

I have a analog problem…
But it was fixed after adding a dummy record in a temporary empty list.
It feels like the ‘being empty’ caused the problem…

I can now report that the Webflow engineers have fixed the issue with empty collections causing Editor to crash.



Hi @bobmatthyssens @biodust yes we just pushed a fix for this. Thanks again for your patience!

1 Like

Hi @Brando,
I was having the issues as per this thread. I now have a problem editing a Link block inside a collection. Is this related at all?Webflow%20edit%20to%20a%20link%20block%20in%20a%20collection

Hi @zorro7120

This doesn’t appear to be related at first glance, however it is difficult to say for sure without some more info.

Can you please fill out a report here with your Read-Only link, this GIF, a detailed description, and any other resources? This will go straight to our support team and we can investigate this further for you :slight_smile:

Thanks in advance!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.