Streaming live at 10am (PST)

Ecommerce : Impossible to add to cart from collection list since a few hours

Hi,

We are running an ecommerce website using webflow for a couple of years.
Today, we found that it fail to add to cart from list items: ex in this page (but it’s the same problem on all pages)

Adding the first item is working, but not the others.
The error is : “Please select an option in each set.”

We did not change anything in the site recently.

In the javascript console we can see a new error:

webflow.ee0e51056.js:formatted:43086 Uncaught (in promise) TypeError: Cannot read properties of null (reading 'id')
    at webflow.ee0e51056.js:formatted:43086
    at Array.find (<anonymous>)
    at webflow.ee0e51056.js:formatted:43085
    at webflow.ee0e51056.js:formatted:31749
    at e.exports (webflow.ee0e51056.js:formatted:8992)
    at webflow.ee0e51056.js:formatted:43015

which is related to webflow js code if we follow the link.

The example page is quite simple: a collection list wrapper to a filtered list of products. The “+” button is a simple ‘add to cart button’:

All the analysis leads us to a (recent) weblow internal problem, but we can not find any other non-working example (apart perhaps this post here ? https://discourse.webflow.com/t/product-variants-are-not-working-cant-add-to-cart/191370

We are familiar with the “restart Webflow” tips and i tried a manual restart in js (invoquing a custom code like this one:

 wf.destroy(), wf.init({
        siteId: 'xxxxx',
        apiUrl: "https://render.webflow.com"
      });

it does not correct the problem, but we can see that just after the restart the javascript error shows again:

Thanks,
Regards,
Thomas.

1 Like

I’m having the exact same problem, need this to be fixed ASAP

Hey everyone, this is a known issue and the fix is on its way. I’ll respond back here when the fix is live so that I can get verification that your sites are working properly.

Also check https://status.webflow.com for status updates.

Adding variants to carts should be working again. Please let me know if your site is still experiencing issues.

@matthewpmunger This is still not working for our sites:

I have uploaded a screenshot of the issue. The first in the Collection list seems to work but the rest dont.

It is now fixed. The site had to be published to see the fix.

visit this link might be your problem sort out : https://zaiditechnology.com.pk/