Ecommerce functionality (add to cart, buy now) not working on newly published ecommerce site

I recently built my first website with Webflow e-commerce. I have built many Webflow sites before, but have never created an e-commerce one.

I followed all the setup steps in the e-commerce checklist portion, added hosting, enabled SSL, enabled checkout, etc. Everything in the setup checklist is complete. I published my site live and SSL is working.

I am trying to test out the live site by purchasing a product and cannot get any e-commerce functionality to work. I cannot add products to my cart and the buy now button doesn’t work. Additionally, the cart button doesn’t show a number on the live site like in the designer, telling me something is wrong with the e-commerce settings, not a product.

The error messages I get read:

  • Something went wrong when adding this item to the cart.
  • Something went wrong when trying to purchase this item.

I tried the following to debug:

  • Creating a new e-commerce listing on a new page of my site for testing.
  • Toggling on and off web payments
  • Disconnecting and reconnecting Stripe
  • Creating new products with different variations of product settings

Among other things. I have read all the similar forum topics and nothing seems to work. I suspect that there is some sort of strange issue with my account. One clue there is that in my project settings under Hosting > Advanced Publishing Options, I see a message indicating that I need to add a site plan, despite already having one. When I try clicking the link and adding a site plan I get an error message there too.

Screen Shot 2022-11-01 at 4.40.33 PM

Since I suspect this issue is unique to me, I tried to submit a support ticket instead of posting here, but had a difficult time trying to do so. seems to send you in a loop, and the contact support buttons don’t actually allow you to contact support.

Here is my site Read-Only:

And here is a link to my live site:

Update – this seems to have resolved itself.

I suspect that it took time for my SSL to be fully verified and for the ecommerce functionality to work.

I will leave this thread open in case it helps anyone else in the future. Also maybe the product or the docs could make this more clear.