Streaming live at 10am (PST)

Dynamic slider doesn't work on https

I checked a site that uses the slider. It has stopped working on the site without authorizing loading of unsafe scripts. Works fine in Anyone found a solution for this? I added the https to the the github script but that didn’t seem to fix it. Anyone else run into this for adding custom code in webflow since the inclusion of SSL?

Please provide detailed information if you have a question.

You are missing the following details in your post:

  • the site that uses the slider

  • the full URL of the github script you are using

  • your public share link for your project

  • the published link for your web page you have the custom code on

@samliew it refers to any site that uses the instructions from @SidneyOttelohe method. In reference to all the sites being discussed before you moved this.

The site works fine at its but without changing anything except the SSL it no longer works on the hosted site. Well, it does if the user authorizes unsafe scripts.

I have two sites that use the slider currently one is not a custom domain so no issue. The other has an issue. The slider is on the main categories template. Any of the main categories would give the same issue at the bottom of the page above contact.

The share link is

the github link is

I was thinking about it. Maybe the solution is to minifi it and just paste the whole code in the custom code section of the site.

What do you think? Or is there a better workaround. From what I see this could be an issue with custom javascript and SSL through webflow. Not just this one script.

Hi jbleroux,

Could you set up SSL so that I can see where the script isn’t working? seems to load fine for me.

eg. the SSL is set up, already I don’t understand. Under the header “you might like these too” is a dynamic slider. It doesn’t work on the custom domain site but works fine on the site. Yes the github loads fine for me too but its implementation in the custom code is not working on the custom domain site without authorizing loading unsafe scripts. Which most visitors are not going to want to do.

Fix #1:

Try changing the library URL to the official version

Fix #2:

I found your problem. You were using which redirects to the non-SSL version of See the difference in the domain name?

1 Like

Thanks @samliew I imagine I might not be the only one dabbling with custom scripts that will run into this issue on older sites.

ok so in future when I look at scripts and want to ensure that they will work with SSL how do I tell? In this instance, this is an older site well 4 months. So before the SSL everything was working well. But obviously I would like to avoid this issue in the future

You have to simply load the script(s) URL as https and ensure it actually loads as https, and that it doesn’t redirect to elsewhere.

Hi, I’m having the same problem. I don’t understand how to change the library url or load a script?
Could you tell me what the two lines of code should be that I need to replace in the custom code bit of the site settings. Didn’t realise this was an issue until the site went live.

Many thanks,

Please ignore…i figured it out. Had code in the header, just had to replace it with:
but in the footer. All works now.