Drop down menus not working for some


I’m having a strange problem. Many users are reporting that the drop down menus don’t work. I cannot find consistency and I can’t reproduce the problem. Does anyone have a similar problem?

User 1:
My Chrome works perfectly with the site, but Firefox is not. None of the drop down menu items/links actually ‘drop down’ except for Events, but that one only has the organizational text, none of the actual items/links in it. By contrast, this embedded image is from Chrome, where all the items/links show up properly.

I’m on MAC OS X 10.15
My browsers are:
Firefox 112
Chrome 112 on macOS (Monterey)

User 2:
Drop down menus do not work for me.

Laptop works fine.

User 3:
I also tried it on my laptop and it seems to work as well.

Here is my public share link:https://parkinsonshawaii.org/

hi @62MoaKane issue is related to breakpoints this mean you can replicate it easily. here is short video to demonstrate this issue but there is more things that need to be solved.