Does anyone else have components that change once you issue a class to them?

I am trying to create a slider, but when I assign a class to it, the slider changes and doesn’t work properly

Hello @redpath4,
Could you tell us more details, please? What class you give to the slider and what do you mean “doesn’t work properly”? Also would be helpful if you could share read-only link to your project. Guidance you can find here: How to Enable a Webflow Share Link - Webflow Tips - Forum | Webflow


1 Like

@sabanna Here’s my link, I see screen shots, I have a program to do that, but do you have another one you suggest to show you step by step what I’m doing, or doing wrong?

I am using “Nimbus Screenshots”, now they even have a video records option. Pretty helpful to me.

Well, you have 2 sliders on your site, one ofthem works good and another one has no slides inside. Which one you were talking about?

Sorry, the one on the home page


Here’s a video of me putting in a class

Well… I noticed, that class “Slider” has settings: display: inline. That will definitely change how slider will appear. So I would suggest: remove that setting from class styling or create new class, which has no changed style settings initially.


@sabanna I’ve tried that, still not working correctly, or as the tutorial video shows

Hey redpath4,

Your issue is that there is a slider on the landing page using the class slider so when you give the class slider to your slider on the home page it takes all the properties from the landing page one here is how to fix it:

Hope this helps :smile:

i would also suggest that you clean up your styles there are around 70+ unused styles they can slow done your website alot

1 Like

@Ahmadz839 Thank you so much that does help tremendously. When you say clean up my styles, what do you mean?

1 Like

Glad i cloud help this is what i meant by cleaning styles: :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.