Streaming live at 10am (PST)

Custom Font won't work on anything that is not safari

So i’m new here and new to Webflow and need help with a font issue.
i uploaded a “Open Sans Hebrew” on the site settings, everything works fine on my Safari. but it won’t work under any other browser.
if i open the chrome console i see my font is set just fine, but the font that is actually there is the fallback font.
see the attached image: main font is “opensanshebrew” but the displayed font is the fallback font “times new roman”

What am i doing wrong? is this a bug?
I tried using other custom fonts - same problem
I tried uploading more font formats and it just got worse as safari stopped working also.

i sent an email to the support but was thinking maybe the community can help :smile:

site is:
read only link:

Make sure you load all 4 versions of the webfont, woff, svg, ttf, eot. These will make sure it loads in all browsers. You can create these with an online webfont creator from a ttf or otf source font.

I tried that and why happened was i wasn’t seeing the font now even on my safari.
i tired adding just one type at a time and figured it’s the WOFF that i add that makes the font to stop working even on the one browser that it did work on.

other suggestions?

Same problem, @Aviry did you solve it?

Hi @Yegor_Trukhin, have you checked to make sure, that you have all the versions of the font uploaded, .ttf, .woff, .eot and .otf.

If you do not have these font versions, you can also go to a site like and generate some additional versions that you might be missing.

Once you do that, republish your site, and check to see if those fonts show up. I hope this helps, Cheers, Dave

1 Like