Streaming live at 10am (PST)

Adobe/Google and installed font problems

I’m mid-way designing a new site and already have issues with the webfont I chose (WOFF). The font works great on my Mac Chrome browser (Version 81.0.4044.129) but the site uses default sans serif in Safari (Version 13.1) and in iOS 13.4.1 (both Safari and Chrome).

I contacted the foundry but they were unable to help.

What it should look like (Mac OS Chrome)

What it looks like (Mac OS Safari, iOS Safari and Chrome)

I have also been struggling with webfonts through Adobe and Google integrations. I tried using both Adobe Fonts and Google Fonts. For some reason some ‘weights’ are fine and others not. Is anyone else having that problem?

Would welcome your help, between webfont upload and integration issues, I have no other solutions to try!


Share URL:

Spent another couple of hours on this, trying many fonts, from Adobe to Google and uploads. Definitely some type of conflict with Safari and iOS, as most fonts won’t work:

What I noticed:
– If I add more than one weigh on a typekit, the selecting menu is grayed out (only one weight is active)
– All fonts I tried worked on Chrome/Mac OS, but none work on Safari (Mac and iOS)
– Found no reports of conflicts like this one on Apple forum


Also, important note—my other live Webflow sites with web fonts are working/loading fine!

Could something go ‘corrupt’ on one site? Maybe a class definition? (the one shown in screenshots above is H1)


Hey Diego, did you manage to resolve this? I’m getting exactly the same issue with custom font not working on Safari MacOS and iOS…?


Hey Alistair,

Unfortunately not. Had to change fonts until I got one I liked and worked. It’s odd, I don’t know why it’s happening, I suspect it has to do with font publishing settings?

Good luck…