Streaming live at 10am (PST)

Custom code changes not showing after publish

We made changes to custom code in the header and body sections. After the initial addition of custom code when we published we DID see the changes on our published site.

We went to change the custom code (had to fix a few urls) and are no longer seeing ANY changes on our published site after publishing.

We tried to look up this issue and found Custom Code Not Updating? - #2 by tato2278 but this was not helpful.

We have tried clearing our browser cache, using incognito, having two separate devs take a look at the publish site, and none of these worked. It seems that Webflow is not recognizing the changes we have made to Custom Code.


RO Link: Webflow - Prenda

Published Site: Prenda

Since you did not share your read-only and published URL we can’t offer assistance.

Please include your site’s Read-Only Share Link with your question.
A read-only link allows the community to view your project without making any edits to it and help diagnose your issue or provide feedback.

If your project has custom code or layout issues on the published site, please share that URL/URI as well.

RO Link: Webflow - Prenda

Published Site: Prenda

So no one has to guess and hunt, can you share what particular code is not rendering? Screenshots are helpful as well.

On the published site you will find GET https://prenda.webflow.io/assets/map-script.js?version=2.1.1 net::ERR_ABORTED 404 (Not Found) in the console. This is because the original tool we used for the static site was Squarespace and our script target was in the assets dir of our Squarespace project.

We’ve since updated this to have our CI pipeline deploy to s3 and are now referencing our s3 object available at this link https://s3.amazonaws.com/mapdata.prenda.co/map-script-compiled.js/map-script-compiled.js.

This is all viewable in the RO link pasted above - specifically in the Custom Code’s Before </body> tag input.

<script crossOrigin src="https://unpkg.com/react@16/umd/react.production.min.js"></script>
<script crossOrigin src="https://unpkg.com/react-dom@16/umd/react-dom.production.min.js"></script>
<script crossOrigin src="https://cdn.jsdelivr.net/npm/emotion@9.2.12/dist/emotion.umd.min.js"></script>
<script crossOrigin src="https://unpkg.com/prop-types@15.5.10/prop-types.min.js"></script>
<script crossOrigin src="https://unpkg.com/react-input-autosize@2.2.1/dist/react-input-autosize.min.js"></script>
<script crossOrigin src="https://unpkg.com/react-select@2.1.2/dist/react-select.min.js"></script>
<div class="search-container">
    <form id="MapSearch">
        <label for="MapSearchInput">Search the microschool map by ZIP code</label>
        <div class="search-elements">
            <input type="number" id="MapSearchInput" placeholder="ZIP Code" maxlength="5">
            <button type="submit">SEARCH</button>
        </div>
    </form>
</div>
<div id="Map"></div>
<div id="Map1"></div>
<script src="https://s3.amazonaws.com/mapdata.prenda.co/map-script-compiled.js/map-script-compiled.js"></script>

We’ve also updated the text in our element to be Search the microschool map by ZIP code - adding the word microschool and we also do not see this when we publish. image

We also added a text block within the page itself that has the content Div render? and this is also not showing up on our published page. We are navigating to the published page by clicking the external window icon right next to our website url image

I think you have misunderstood the 404 error here…
The resource https://prenda.webflow.io/assets/map-script.js cannot be correct, since assets uploaded to Webflow are hosted on a CDN (i.e. uploads-ssl.webflow.com/{{site-name}}/{{asset-name}}.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.