CSV upload to multi reference field

I am trying to upload a CSV to the CMS to update multi reference fields.

Issue: Webflow does not import all items. For some reason, it only imports a few, but not all. They are all formatted the same way.

Example: Trying to upload 3 items into the reference field.

Google sheets: 3 items


Webflow: only 1 is imported


When I search, the items actually exist in Webflow, for some reason they are just not matched during the import…


Let me know if you have any ideas :slight_smile:

You might want to take a look at this page => CSV import now supports reference and multi-reference fields | Webflow Features as it contains some formatting rule info.

That is the thing! I already checked the formatting and it works. For example, if I now simply take the one row of data and upload it to webflow, it matches correctly:

It is only when I upload larger files, some connections get lost. I even tried it in “small” batches of 70 rows per import - still causes issues.

There is really no way for me to debug this for you. Things I would do would include validating the CSV file to make sure there is no formatting issues. There are online validators you can use. If the file passed then I would probably look a leveraging something like powerimporter for example. I usually export from WF sites to other systems, not import.

1 Like

I used powerimporter with the same CSV and it worked. Thanks for the tip.

1 Like