Streaming live at 10am (PST)

Could not find snapshot of id:


When I go a backup of my site (tried different backups) and I try to go to a different page other than my homepage (CMS or Standard), I receive the below error.

Is anyone else experiencing this issue?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


Same here.

Hope this gets fixed soon.

This is also affecting me. None of my backups have anything other than a home page.

Same here… Super, super concerning given how critical backups are. Surely someone from Webflow has something to say… it’s been over 24hr.

Same here oh its been 24hours? hmmm

@moofawsaw @botski @cassybaptista @Jay_Gilden1 @jayaranda these definitely sound like bug related cases. If you haven’t already, can you each please contact our team directly to get those resolved?

We’re seeing a few reports about this and our team has a few solutions unique to different projects. Thank you so much!

Update: Are you seeing the same behavior when trying to restore backup from the site settings under the backups tab?

Same behaviour in the site setting as when in designer.

Thank you so much @botski

Can you please contact our team directly with your site information so that we can look into your project? Our team is actively looking into this issue.

Yes it still the same. Error prompt from the backup preview.

@moofawsaw @botski @cassybaptista @Jay_Gilden1 @jayaranda

Our team has identified the issue and we’re actively working on a fix for being able to navigate between pages while previewing a backup of your Webflow sites in the Designer.

Thank you all so much again for reporting this and for you patience while we work to resolve it. I’ll follow-up as soon as the fix is pushed live.

1 Like

Hi everyone!
@moofawsaw @botski @cassybaptista @Jay_Gilden1 @jayaranda

Thank you so much for your patience and kindness as we worked to resolve this issue. This should be resolved now and you should be able to navigate through those pages in backup previews again.

If you’re still seeing this error or something else, please let me know, or contact us and we’ll look into it right away!

Thank you again!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.