Confused about canonical URLs and 301 issues

Hey there!

currently struggling to understand how webflow canonical URLs is working. On the site setting > SEO section > Global canonical tag URL I have placed my main domain with https://mydomain.com.

In the publishing section I have both domains added. Is this the issue what I have.
https://mydomain.com
https://www.mydomain.com

If I’m checking i.e. Ahrefs.com there are dozens of issues regarding like this:

What I’m doing wrong?

You didn’t share your actual domain, so I’m speculating here.
Most likely you have mydomain.com set as your default domain. That works fine as long as your DNS supports CNAME flattening and you have it all configured correctly.

But in that case your canonical is https://mydomain.com without the www.

Oh I thoughs I should post the orginal URL…

Can I delete the www section in the settings?

thanks-

Click make default next to it, and republish.

What happens with www.pembe.io ? will it redirect to https://pembe.io?

and should I delete the www or remove it completly?

edit:
after making without www to default

on the website I got the follwing messages and the website is not available:
to many errors redirecting

^ This will fix your questions about canonicals and 301s. Right now you do not have a default domain, and Webflow does not know what to generate in the sitemap.

but that’s not the solution to have a website which is not available? I’m still missing the link what to-do?
redirect-error

It looks like you might have an atypical DNS setup.
Are you using a reverse proxy, or something like Weglot?

It appears you have 3 A records defined on your www.pembe.io and they’re different from your pembe.io A records.

You’ll need to find out what those are for and what they’re doing.

At the moment it looks like requests to www.pembe.io are being redirected, so when you make it the primary you get an infinite redirect loop.

I’m not sure how your particular DNS setup is meant to work.
I don’t see a flattened CNAME for pembe.io but if your setup is redirecting www.pembe.io to pembe.io then you may just want to make that your canonical;

As in https://pembe.io for your site-wide canonical setting.

that’s a good hint, we have hosted some parts on amazon (the application) but the homepage is on webflow. just checked and I see this in my DNS setting:


I just checked another DNS query tool, and it’s showing some additional details-
Are you using Webflow Localization?

I am checking some of my localized sites now and I’m seeing a similar setup but only on some of them.

Seeing this, I suspect your app is running on a different domain or subdomain altogether like app.pembe.io and should not interfere.

That brings us back to the redirect issue with www as the primary domain. It’s not a locally cached redirect issue ( I’ve tested that ) which could mean that you’d need to set www as primary and then wait some hours for Webflow to catch up regarding any internal updates, DNS propagation, etc.

I think at this point I’d contact Webflow support and explain the situation. You want www as your primary, but you’re getting too many redirects error.

hey Michael,

I don’t use the localization tool. You’re right, I have a lot of subdomains for different topics, like mail server or application servers… the main homepage. I will try this tonight and check if it’s working tomorrow. Thanks-

ps. I contacted Webflow support.

After making www to default and waited a day, now it works. Thanks so far.