CMS Collection not allowing me to bind items to site elements

HI everyone,

I hope this is not a repeat issue, I have tried searching for a solution, but haven’t found any.

I created a CMS Collection on my website, used the Webflow Blog Post template, no issues, everything works fine. But, when I add the Collection List block to a page and want to bind the CMS Collection to the respective headings, images etc., I can’t do it. The Dynamic Style Settings menu only shows a few options, and none are relevant:


For example, this is what I see when I try to bind the title of the blog post to a H2.

Maybe I’m missing something obvious, but I just couldn’t crack this one. I would be grateful for any help.

Here is my public share link: Webflow - Město jako Brno

hi @Tereza_Navarova it is, but you are not first who have problems to figure out “how” as it is IMO bad change decision trying to improve WF DX with breaking all design principles. You need to click this mini radio button that will open offer with linkable tags .

1 Like

Oh god. You have to be kidding me :grinning:

Now it works, of course! Thank you so much for your help, and for God’s sake, Webflow, improve this!! I spent an hour today trying to figure it out… 5 years of studying interaction (and other) design and 6 years of it in practice didn’t prepare me for this “pattern”.

Once again, thank you and sorry for the duplicate question. Hope this helps someone else along the way too.


hi @Tereza_Navarova no worry. Welcome to WF world :face_with_hand_over_mouth:

1 Like

Thanks for your question @Tereza_Navarova and thanks for your answer @Stan . I was having the same problem and took hours to find this topic. The tutorial videos are out of date

That’s crazy I was just going through the same issue! for 5 hours, crazy that the little radio button was right there, thanks a bunch @Stan @Tereza_Navarova

1 Like

Glad you finally find it @maroo . This little purple bug is one of worst UI decision I have seen for long time, resulting in many confused users.