Can't type spaces with spacebar in rich-text element editor view

When our client is in Editor mode for their site, they can’t type spaces with the spacebar for rich-text elements under their blog collections. All other fields work fine with no issues, but for some reason all the rich-text elements won’t allow it.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey Ian, I have seen that on occasion as well.

Try having them turn off all browser extensions temporarily, then login to the editor again and see if the problem still exists.

Hey Michael,

Thanks! Just tried that and it didn’t work. Turned off all extensions, signed out, and restarted the browser. The problem is still there on Chrome, Brave, and Safari…

Super curious about something, if it’s easy for you to test.
Rather than typing…

Rich text with spaces

Try typing that after pressing the spacebar first at the start of the line…

[space]Rich text with spaces

Just looking at some Chromium and TinyMCE bug reports and I’m suspicious. However Safari is based on WebKit.

Two other questions-

  • are you seeing the same problem when editing Collection items in the collection item pop-up window?
  • is all of this happening on the same computer, but works ok on other computers?
  • do you have another computer on the same network that you can test?

These are just theories, but one of the things I’ve noticed is that the “broken spacebar” issue only happens when I’m blogging at cafes, which often have unusual network & firewall configs. Seems possible something is getting blocked or revised.

@memetican Didn’t work - same issue. I can [shift+space] and it works throughout the whole RTE, but normal [space] doesn’t.

  • I’m not sure where the collection item pop-up window is. I’ve tested on the backend within the Designer view and have no issues. Seems to be just on the Editor view.
  • Same problem on multiple computers
  • Yep - tested on other computer with same issue

Hey Ian, I’m using Chrome + Windows on my setup and not seeing this issue on my sites. Since you’ve tried multiple computers & browsers, I think that narrows it down to one of 3 things;

  1. Your network configuration and specifically firewalls, proxies, or routing
  2. Where you’re at in the world and the CDN you’re being served the editor.js files from
  3. Your site itself.

I’m going to PM you with a video on what to check.