Can't link the site to domain, Even after adding the records!

Hello Guys,
I am trying to add a domain to my webflow site, but for some reason it’s not adding up.
It’s showing me to add records webflow has provided after adding that also I am getting the same error.
It’s been more than 12 hrs for this but still the same.
For refence this is the site:

I don’t know what to do, Can some one help me with this?

Looks like you’re using cloudflare for your DNS?
On your 2 A and CNAME records, switch off the little orange proxy switch for those 3.

Okay, Let me try and get back to you.

It’s already off. Is there anymore solution.

Could be something with your cloudflare https configuration; I’d contact Webflow support, they are well practiced with troubleshooting these issues.

Seems to be working for me now. Did you change anything?

DNS propagation may not have completed, and now it has if you didn’t change anything on your end.

Yes, I have changed some Cloudflare setting and I managed to go live.
The issue was arising from CNAME.