Missing reciprocal hreflang

Cheers!

I’m currently testing out the new localization features, using Norwegian as my primary locale and English as an alternate.

My auto-generated sitemap is getting “missing reciprocal hreflang” as an error from hrefs:

Which refers to this:

As far as I understand, the sitemap structure should have values like hreflang=“no-no” to make it self referencing?

Is this something I should be resolving in my implementation, or is it something Webflow should implement a solution for?

My localization settings looks like this:

1 Like

I have the same problem

Got a reply from support earlier today. My assumption about where the fault was is wrong, but they’re working on a fix as a high priority issue.

We have the same problem: Since releasing an additional locale, our page score crashed with “Missing reciprocal hreflang (no return-tag)” being the main driver. Do I understand correctly that Webflow has to release a fix for that (and are working on it with priority)?

I’m seeing reciprocals fine on my sites, both in the pages and sitemaps - but no self-referencing hreflang tags in the pages. I see that as minor.

Share your published site link if you want someone else to check.

Well you could fix it for yourself with script or a reverse-proxy, especially if your paths are untranslated. Questions relating to whether Webflow sees it as a bug and whether they’re working on any fixes can only be answered by Webflow. Contact support if you need that info.

Hi @memetican thanks for picking this up. I did some further digging into canonical tags and hreflang, trying to wrap my head around it.

I added canonical tags to the header on all pages (self-canonicals since we don’t have duplicate content issues per se). However, I now get errors from ahrefs “Hreflang to non-canonical”.

My (limited) understanding is that our hreflang tags point to the respective page for the locale (e.g., to Der erste KI-Assistent für B2B-Teams). However, we defined https://uify.io as canonical, so directing to Der erste KI-Assistent für B2B-Teams points to a non-canonical page. Am I correct to assume that each localized variant of a page should be canonical (and indexed accordingly)? So how do I do this in Webflow? When switching the locale for a given page in the designer, the header code block is locked, so I can’t add a canonical tag manually. Or am I completely misunderstanding this?

Here is my page link:

https://preview.webflow.com/preview/uify-staging-new?utm_medium=preview_link&utm_source=dashboard&utm_content=uify-staging-new&preview=7a8c833f61b9beac185155fbe4c719e7&workflow=preview

Thanks!

You don’t need to write your canonicals manually, use Webflow’s built-in site setting for canonical URLs. Currently yours are a bit broken - as the canonical for e.g. https://uify.io/de should be https://uify.io/de, not https://uify.io

In my localized sites Webflow’s canonical feature handles this perfectly.

What I see missing on my sites is only the self-referencing hreflang within the page <head> ( it exists in the sitemap ). Including this is considered a best practice but really seems redundant to me anyway, since that info is already clearly in the page ( canonical + lang attribute ), and in the sitemap as well. But screamingfrog will scream without it.

Hi Kevin - can you elaborate what the actual issue was and what Webflow said in terms of fixing it on their end? Thx!

Mm, looking back at the support correspondence a bit closer, they thought the issue was regarding missing hreflang tags in it’s entirety. So it wasnt related to this issue after all

Screamingfrog doing it’s job and screaming about everything x’)

Thanks for the hint regarding Webflow’s canonical setting - removed all the manual tags and used this one. Saves me the manual maintenance…

Now I’m exactly where you are with the missing reciprocal tags. I get your reasoning for those being somewhat redundant anyway, but my OCD struggles with the bad page score due to this…

Your reciprocals are looking good, it’s the self-referencing ones that are missing

For example, your Norwegian videoproduksjon page here https://www.mediaveien.no/videoproduksjon contains this hreflang;

<link rel="alternate" hrefLang="en" href="https://www.mediaveien.no/en/videoproduksjon"/>

And the English version here https://www.mediaveien.no/en/videoproduksjon contains this hreflang;

<link rel="alternate" hrefLang="no" href="https://www.mediaveien.no/videoproduksjon"/>

I’ve no idea if Webflow is planning to add the self-referencing ones, but it’s a feature I’m thinking of adding to my reverse proxy framework which is primarily for SEO clients.

If you’re only concerned about Google, and fine with screaming frogs, you should be able to create that using custom code. I think the algo would need to be;

  • Get the lang attribute from the <html> element
  • Get the current URL( origin + path, no query )
  • Check for a <link> with hreflang = the current lang from the <html> element
  • If none found, compose a self-referencing link using those two pieces of data and add it to the DOM

Not sure if this will help any of you, but make sure to go into your site settings (General - > Localisation - > Language code) and remove your primary locale language code. There’s a new text box now which says “setting a language code here will override all secondary locales your site supports”.

We have a slightly different problem, which is Hreflang conflicts within page source code (no self-referencing hreflang). Extremely frustrating, as there doesn’t appear to be any fix for it and Webflow’s support team hasn’t got back to us.

I have lost count of the amount of bugs I have found in this localisation update (not counting imperfections or small things that could be improved). I find it unbelievable this was rolled out. Should never paid up front for the year.

Hey Aaron, easy to fix with script or a reverse proxy.
I suspect Google doesn’t care much actually, it already knows the current page’s locale from the html lang= attribute and the canonical.

Question- you mentioned other bugs, and I’m trying to make a “state of the product” highlights that you’ve encountered. Overall I’m very happy with Localization but there are a few key major problems.

What have you found?

Got another update from support that this was fixed now, and it seems that it is. Good stuff

Yepp, can confirm! Nice!

There’s still a problem though with the hreflang on the homepage where it is set to e.g. “/en/” instead of “/en”. This leads to a 301 being the target of the hreflang…
Support request is open at webflow. Will update here, once I got a reply.

The 301 problem with root hreflangs linking to e.g. “/en/” mentioned above now is also fixed! :slight_smile: