Cannot load anything in CMS

I am unable to load any CMS items in Webflow editor. I have tried multiple collections but none of them load. The same is true with the Designer.


This is affecting multiple browsers (Chrome / Edge). There are no issues with my internet connection. The CMS is currently unusable.

I have noticed a slow degradation in loading speed for collection items over the last year but this is the first time they have simply failed to load at all. Is anyone else having the same problem?

Here is my site Read-Only: LINK

In the bugs category posts should share a read only link. This would allow someone else to check if your issue is project or client related.

Since you did (I missed it at first) I have no issues loading CMS items. Have you tried accessing the designer from a private browser session with no extensions loaded?

Yes, I always share a link! I’ve tried again and the items are now loading. However, this does seem to be erratic in terms of loading speeds. Some days it hangs for some time (10 secs+). Today, it simply didn’t load.

We have 717 items in our Articles collection currently. This will only grow over weeks and months - how does Webflow handle serving this amount of items in a list in the editor? It seems it is really struggling currently.

I can’t comment on performance with larger collections since I don’t use WF’s CMS with large projects and have nothing to test. Maybe someone else who does can chime in.

I only run the designer in a specific browser with no other pages loaded and zero extensions to avoid issues. I rarely see any.

Hi @RobJDR

Do any of these collections have links to video links? As we are experiencing an issue with the API and you can stay up to date here: as this is affecting thousands of sites and many different platforms that use the API.

Have a Great Day and Happy Designing,
~ Brandon

They do and it looks like you resolved the service issue. Will keep an eye on this, thanks.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.