Cannot change font in Rich text of dynamic template

I’ve chosen webflow one free CMS template to try. And I cannot change the font in my Projects Template page. I see that it somehow inherits font style from Body style. How can I delete that inheritance or change general font of Body (I cannot do it also)?

Thank you!

Here is my public share link: LINK
(how to access public share link)

Hey @akhalizev

Glad to see you’re trying Webflow.

Looks like you’re trying to style a Rich text component.

The Rich text component is made up of other elements like headings and paragraphs that inherit global styles.

The template you are using has these global styles set for all headings and all paragraphs. That is why, you can’t apply a new font to the Rich text component as a whole.

You need to style each element separately.

If you need a different style for the project page paragraphs and/or headings inside a Rich text, you can watch the following video:

or read the help text here:

You can learn more about rich texts here:

Please, tell us if this is helpful.
Best of luck,
Anna K

1 Like

Thank you, Anna!
I can reproduce that video tutorial, but in case of my template this won’t work. I can select Rich text element only as single object and cannot select Headlines and Paragraphs inside it.

May be you can watch it, taking that template and trying to reproduce?

Thank you for help!
I definitely wish to buy a subscription.

Hey @akhalizev

I forgot to mention that when a Rich text component (or any element for that matter) is in a dynamic list or page, and it is bound to a dynamic item field, then you cannot edit the component. You need to:

  1. unbind it
  2. style the elements inside
  3. bind it again

This is how you bind and unbind dynamic fields:

Hope this explains it better.

Best of Luck,
Anna K

Anna, thank you very much for this support!
It works. I moved around that unbound checkbox but didn’t check it.


1 Like

You are most welcome Anatoly @akhalizev

Hope you are liking Webflow. Please, send us a feedback.

Best of luck always,
Anna K

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.