Streaming live at 10am (PST)

Button has fill in published site but not in the designer


I’ve created a form with a secondary button that only has a purple border and text, no fill (or a white fill). It all works and looks correct but on mobile on my published site, the button has been given a purple fill automatically. (Element style when I inspect). I have tried giving it a forced white fill or alpha value 0 but nothing works.

Link: Read only link

Screenshot 2020-02-13 at 13.52.13

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @Bee_Neat,

You have an interaction on the button with the initial state BG color as Purple.
So when the site loads, your interaction is saying “Start off with a purple button”… so it is :slight_smile:

Hope that helps!

Oh wauw, how stupid of me. Thanks for clearing this up so quickly!

1 Like

You’re welcome. Definitely not stupid, just a mistake to learn from :smiley:

Hey Mark, so I removed the interaction (basically rebuild the button with a new unique class, no interactions) But I keep getting the same view? I have been cache refreshing my browser but it still shows up the same.
Would you know a way to fix that?

Have you tried incognito mode after re-publishing? It take a few minutes sometimes but should be mostly instant.

Yes I have, and multiple browsers

Can you share the published link please, and a screenshot of what you’re seeing, that you shouldn’t be seeing? :slight_smile:

Of course.

I’m seeing this

While I should be seeing this (webflow)

Public link

You have leftover interaction affecting secondary_button. Delete the interaction in the panel and you’re good to go.

Aha that’s it, that worked! Thanks for taking the time to help out!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.