[BUG] Can't open code editor from an embed component

Hey all,

I’m experiencing a bug when trying to edit a component I have created to store some global styles (css) in. The component simply exists of an embed element. It has always worked, untill today. Since today I’m receiving this error when clicking the cogwheel:

POST https://rum-http-intake.logs.datadoghq.com/v1/input/pub9238a331d14b5f49624bb5e93b1bbd64?ddsource=browser&ddtags=sdk_version%3A3.6.12%2Cenv%3Aprod%2Cservice%3AWebflow-Dashboard%2Cversion%3Amain-7aa45cc013078e2b9def076ddf9bb0d99acbf3a5&batch_time=1687869247112 net::ERR_BLOCKED_BY_CLIENT
Screenshot 2023-06-27 at 14.51.34

I’ve tested it on my other site, and it also stopped working there.
Besides that I have also asked a colleague to test it. But it also doesn’t seem to work there.

Does anyone know what is going wrong?

Thanks in advance.

Here is my site Read-Only: https://preview.webflow.com/preview/test-2-62e29d?utm_medium=preview_link&utm_source=designer&utm_content=test-2-62e29d&preview=d1d6ce4c6af57a0ac637261304ad6bc4&workflow=preview

I’m not sure if this will help when published, but once I disconnected your embed element as a component, I’m able to open/edit it as expected. There might be some recent change with Webflow that’s disrupting the embed once converted to a component?

That’s a good fall back method I suppose, although I’d lose the features of it being a component and handled at one place.
I think you’re right about there being a change, as it is suddenly not working.

What’s strange is that I do not receive the error from your original post. Will be interesting to know if you still get this error message after unlinking from the component.

Also, when I use the html embed cog wheel icon, the code editor will not open up. But when I use the “open code editor” button in the settings panel, it opens as expected.


I have exactly the same issue!