Streaming live at 10am (PST)

Can't access Editor Mode

Hello, I can’t access Editor Mode on any website.

I tried from two Macbooks and onto different Webflow accounts.

Also tried to access the Editor from “link.com”/?edit and from Editor in Project Settings.
On both it asks for LOGIN DETAILS and after that an error toast appears “Because you’re a site admin, you’ll need to log in to the Editor here.” that takes me to Project Settings but the same happens again and again.

What else can I do? Thanks a lot!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

If you built the website and it lives in your account, you can load the Editor (without logging in) from either the top button from your Profile or within the top-left menu in the Designer:


Since there are only a limited amount of seats available for collaborators, Webflow prevents you from needing to create your own account and instead gives you access to the Editor in the two ways shown above. Clicking either of those authenticates you as the website account holder without needing to use your account credientials or creating new ones just for use in the Editor :+1:

1 Like

The whole reason of this post is because I can’t enter the Editor mode from neither of those places. When I click them it takes me to /?edit=1 and ask for login in…

I’m the owner of the account and website. It’s a f infinite loop…

Hmm, that’s strange behavior. Clicking those should take you to the /?edit=1 but on my end the page refreshes almost immediately and I see the Editor controls without needing to log in.

Can you try logging out and back into your account and giving it another try? If that doesn’t work, are you able to access the Editor from either of those places within an incognito window? It’s possible one of your extensions is conflicting with that authentication.

1 Like

Oh, so I tried on Incognito and I also got a red flag but pointing out the exact problem:
“We’re having trouble with your browser’s cookies. Make sure your browser accepts third party cookies”. So I simply allowed webflow and webflow editor cookies and now it works! Thanks!

1 Like

So glad you were able to figure it out :tada:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.