Streaming live at 10am (PST)

Background image not retaining size settings

Hi again, @Brando, @cyberdave

and here I am with another bad bug. Easily reproduced.

  • create div, give it a background image, set it to contain or cover
  • set the div to display: none
  • set it back to block
  • background image size is reset

Just in case, video of the said problem.

ps: nevemind the fl.ux yellow overlays going crazy :smiley:

I am experiencing the same problem.
Every change to a block will automatically change it’s background image to a default, non-cover position.

Yep, I can consistently reproduce this behaviour on every project so I didn’t bother with read-only links. Looks like recent bug, cannot remember things like that happening earlier.

Another problem is that cover and contain buttons behave erratically (latest chrome). Here it is. Clicking on the buttons is inconsistent and takes about 2-3 clicks to actually make a switch. At the same time background image reflects the change from the first click even when interface doesn’t show it.

It feels broken and I do not like my Webflow broken :slight_smile:

1 Like

Hi @dram and @avivtech,

Thanks for posting about this.

This is a known issue and the team is currently investigating. As soon as we have more details, I’ll let you know you immediately.

Thanks in advance for your patience.


Our team is having ta similar issue with background images not retaining their size.

Running latest Chrome on Win 10.

Me too. Following. :slight_smile:

Same here. Every time I open the Background Image panel the settings reset.

Good to know @webflow is on it, @Nita! Also having this issue. The stylings that seem to affect it for me are:

  • Setting borders/colors
  • Setting text colors
  • Altering background Cover/Contain settings

And especially (for me) when these settings are on an Anchor tag element when it is a Link Block.
I’m guessing it has to do with settings Anchor stylings in the various iterations throughout a design and the compiled CSS being generated differently each time.
An undo fixes it for me, but repeat changes initiates the problem each time all over again.

Not to conflate this problem by adding another issue, but it likely relates to button clicking in the palettes so I’m adding it: I’ve noticed for some time that clicking on a color sometimes doesn’t change it unless you choose a different color swatch and then click back on the color you wanted.

Hi @Lux @fernando1lins @adiggy @dinko @dram @avivtech

​Thank you again for posting about this background image issue.

​I wanted to give you a quick update on our progress — the team was able to identify the root cause of the issue, and we’re currently working on fix.

​We should be able to deploy this fix soon, and we’ll be sure to let you all know when it’s live.

​Thanks in advance for your help and patience on this.


I have the same issue. It’s not just background image thats been wacky the last couple of weeks. One thing thats been very frustrating is the overflow setting jumping back to default everytime I change anyting on the class.

Hi @Svarte_Peter_J_Barte

Our team was able to push a fix for that overflow issue. Can you please try logging out, completely closing your browser, then log back in and see if the issue persists?

​Thanks in advance.

Hi @Lux @fernando1lins @adiggy @dinko @dram @avivtech

​Good news — a fix is being deployed for the background image issue right now!

​The fix should be live in the next couple of hours, and a quick refresh of the Designer should give you that update. :tada:

@allykat87 I merged your topic with this existing thread :slight_smile:


My site is suddenly not retaining ‘cover’ or ‘contain’ background settings. As soon as I edit another part of the background -the position or background color - it becomes undone. Anyone else having these issues?

Hey Ally! Yes, I’ve been having this issue myself. Looks like they’ve solved it 3 hours ago by the looks of this post?

(I haven’t been able to test it yet myself, so I don’t know for sure if it’s fixed.)

@adiggy Sigh - unfortunately mine is still doing it. I tried clearing my cache and everything

Not yet fixed. The team is on it though so hopefully not long now.

1 Like

Thank you very much for the update :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.