Background Image behind rich text images in Blog CMS

Hi. Im working on my blog in CMS. I’ve added images in the body using Rich Text. However when I look at the page I can see an image is in the background of the image. I can’t seem to figure out where that’s coming from so I can delete it. I’m wondering if I have some setting on my site thats doing this, as Ive had this problem before on other items that get a background image behind them that I didn’t particularly put there. I’d really appreciate any help.


I chcked the first image in rich text is coming from blog post Mina + George with the address

My suspect is the above photo-image.

If solution is found for one photo-image then most likely the same solution can be applied to all the other images-photos on the page.

I will inform you if I find out more details.

I added the photo in with rich text through the CMS Blog Posts. But I how do I edit images in rich text as they do not show up on the navigator.


“But I how do I edit images in rich text as they do not show up on the navigator.”

As your data is coming from blogpost, you would modify blog post sothat correct data comes into other pages.

Following screenshots will help you to edit images in rich text field inside blogpost.It is from the blogpost Mina+George.

Click the image and you will see 6 element menubar on top of the image.


Click the tool(far right side = sixth element) icon of menu bar.You will
have the following.

There are 3 options Basic, Size and Link
Click Size


At the bottom of menu for Size Click the down arrow (at present Auto is selected)

You have options of
Full Width
Original Size


Select Custom e.g. 30%, 40%, 50% etc as per your choice for the best result
Screenshot has 30% selected.
You can also use PX(Pixels) instead of % size.


Similarly you can check all other options available for image editing for getting best result.

Let me know if you have any questions.


Thanks. I see how to edit the size but I cant see how to delete the background image thats appearing underneath the photo.

Go into your cms item page and unbind the rich text field from your CMS collection:

Then go into a paragraph (double click it) and add an image:

Any image will do, it’s just so you can style the image:

Now click outside the rich text field, and then click on the image. Make sure the style thingy looks something like this:

Then check to see if you have a background image set for images nested inside of rich text fields:

Remember to re-bind the text field after!

Thanks! It still shows up when I added the photo the way you explained, and looks like it says background is transparent. Here is a link so you can see. Is there something else I could be missing? I thought for sure that would solve it. Ugh.

Oh wait! I figured it out, yeah! Looks like the background image is behind the “figure” not the image.

Again thanks for your help I would not have figured this out without you!

1 Like

Hooray! Glad you figured it out :slight_smile: