API call to multi-reference field in collection no longer working

I have been running a PHP script that uses the Webflow API and CMS collection to perform some data manipulation tasks for over 2 years now and it no longer seems to be able to properly connect in relation to a multi-reference field in a collection. The collection names, item names, slug names, and field names haven’t changed and neither has the ids for any of these. When I call them up using a test GET request to the API all the items appear to be present but it’s saying the following errors but the referenced item is findable when I run my own separate test. Why won’t it work like it always has? I’ve changed nothing in my CMS, website, or PHP scripts.

[24-Oct-2023 19:23:15 America/Chicago]
“msg”: “Validation Failure”,
“code”: 400,
“name”: “ValidationError”,
“path”: “/collections/63d80c1e8364f9cbdc256d8b/items”,
“err”: “ValidationError: Validation Failure”,
“problems”: [
“Field ‘neighbourhoods-3’: Referenced item not found: ‘63d80c1e8364f93c8a2570ce’”
“problem_data”: [
“slug”: “neighbourhoods-3”,
“msg”: “Referenced item not found”,
“value”: “‘63d80c1e8364f93c8a2570ce’”
“extensions”: {
“input”: {
“collection_id”: {},
“item_id”: null,
“target”: “live”,
“mode”: “live”,
“need_staging”: true,
“need_live”: true,
“need_collections”: false,
“need_staging_draft”: false,
“isPatchMode”: false,
“isSilentMode”: false,
“skipInvalidFiles”: false
“meta”: {
“authType”: “oauth_user”,
“userId”: {}

Any chance you’ve done a site restore? It would change all of the CMS item ID’s.

Barring that, there are quite a few reports of problems with both the v1 and v2 APIs currently as Webflow transitions. Support may be able to give you more details on known issues.

I have before and I’m aware of the issues this causes but no, that is not the issue since all ids still match. Nothing has been changed on my end. Just doesn’t seem to be working now.

Transitions to what?

API v1 to v2.
Have you contacted support yet?

Yes and I’ve told them that my entire automated workflow is at a halt until this gets resolved. This is a high priority issue and no response yet.

Yep and I’m also seeing reports that the V2 api is rate-limited to 5 calls per minute and the V1 api is responding very slowly. At the moment, it looks like Webflow took on too much at once, and is in the very uncomfortable position of a boa trying to digest a porcupine. Ambitious, but perhaps not wise.

The best you can do for now is try both APIs, and see if you can make something work, or consider a site redesign that works around it.

Webflow’s change management has been abysmally poor this year and they are paying the price hard right now. The engineers are basically overwhelmed. I have one support request in which is nearing a 1 month wait.

I recommend self-help on this, don’t expect it to get fixed tomorrow.

My entire website is no longer populating with new data. It is at a complete failure.

Same issue but different context :frowning: Webflow 'Publish an item' Module in Make.com isn't publishing - #4 by memetican

I don’t know if I can handle another week of API v2 drama lol.

We also identified an issue with reference fields returning a validation error of referenced item not found even though the referenced item exists and is published. The issue started on 23 October for us with no changes to our code. Webflow has been informed, and I’m sure they’ll prioritise a quick fix.

Not fast enough. I’m now paying a developer to update to v2 API. Did Webflow provide any advance notice of the changes that would be implemented and potential for issues or was this out of nowhere?

Not sure if you are upgrading purely to overcome the issue, but note we use V2.

I have exactly the same problem as you (since October 23).
It’s not at all due to the API version, I was in V1 and I’ve just switched to V2 but the same problem.
All I can do now is wait for the webflow team to debug it.

I am having the same issue without api use. However, I can see the console spitting out the “referenced item not found” error when it clearly exists… This error is after an editor publish action

I believe the error… could be… that for some reason the “value” prop of the referenced item is now an id wrapped in single quotes… which is strange and could cause validation errors for strings tested for equality.

‘[id]’ !== [id]

Screenshot 2023-10-26 at 6.40.55 PM

I’m running into the exact same scenario where all my make scenarios are failing due to
“[400] ValidationError: Validation Failure
Referenced item not found”

Just to update for others, webflow told me this was just resolved and I just need to do a full site publish again to get everything working and my issues seems to be resolved since publishing!

1 Like

@Jesse_Reichenstein, we still get validation errors with valid multi-ref items when updating CMS items. Creating new CMS items works as expected. Are you experiencing the same?

@MeldAPI Hi Shane, we are stull getting same error, did you manage to resolve?

Thanks @FreddyFordo , it isn’t resolved unfortunately and occurs when updating CMS items containing either a multi & single-reference field. Webflow engineers are investigating.