ALL my styles on a new page just disappeared

Hi there,
I’m not sure if there is any hope here for me, but ALL my styles from today just magically disappeared from my project. Older classes remain in tact just fine, but all the new classes I created today since about noon have been unstyled and now my work is just a mess of divs and text. It’s not even that the class styles became disassociated with my sections, they flat out are not even searchable in my project. I’m at a loss, and trying to avoid the extremely laborious (and frustrating) task of starting over. Do you guys know what happened??

I’m posting this in the design help section, but not sure if it could be some kind of bug as well?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @SaraB

Please provide a read-only link for the community.

Secondly have you tried restoring from a backup?

1 Like

Hey Matt!
My project contains sensitive client content so not comfy sharing, but I had no idea the backups thing existed! You just saved the day big time. Best feature ever. THANK YOU SO MUCH! No one wants to end a Friday on such a bummer.
Still no idea what happened, but who cares. :slight_smile: Sending you a digital hug.


Glad to help! And yes backups are amazing and easy to use. Also you can use cross-site copy and paste to only bring certain elements from the backup over to the current version. This can be helpful if there were changes made in-between the backup and current version that you want to keep and only need to revert one or a few elements back. Delete the current element and then copy/paste the restored element back in.

Small note: If you can’t share your project link, please mention that up front and we won’t bother you about it. :wink:

Definitely make use of the manual saves too - especially after a period of intensive work on the site. The auto back ups provide some peace of mind, with manual backups you can realllly rest easy :slightly_smiling_face:

Oo awesome, I did not realize that either. Just fell in love with this tool even more. Thanks so much for the additional guidance and tips and following up even after you resolved my issue! (and also for helping out this forum newb with question-posting-protocol.) Thanks again :slight_smile: Hope to see you around here.

You’re right :slight_smile: Thanks a bunch. Keeping this in mind for sure and adding it to my automatic workflow. Thank you!

I also didn’t know about the backups and luckily it worked and kinda saved my bum, but still had to redesign and redefine certain parts…have no idea how the fuck-up happened, on my side I’m 110% sure I didn’t acces the editor before - I would really like to have a explaination of what’s causing this issue because is heart wrecking and a bummer…