Streaming live at 10am (PST)

::after / ::before what's going on?

Hello everyone,

I need some help! I have an HTML embed that uses the CMS for data attributes. The problem I am having all of the sudden is that if I make a change to some code I had in there for a while, the video example happens. Even when I undo the changes are re-publish, the damage has been done and none of the items appear.

Does anyone know what’s going on?

Hi @moofawsaw

Thanks for posting about this. This looks related to an issue we just pushed a fix for.

Can you please refresh your designer, republish and check the live site once more? The dynamic assets should be showing up as expected now.

​Thanks in advance, and I’m standing by for your reply.

Hey Brando,

I just tried again for both Chrome and Safari without any luck. I noticed the issue appear about 2 weeks ago but I decided to work around it until now.

It happens when I change anything about the code. I thought it was just my code but it tests well in codepen.

The strange thing is it seems to happen when I change code on that page only.


Thanks for clarifying this!

I’ve reported this issue to the team and we are investigating it now.

I’ll post back as soon as I have more information for you.

Standing by. Hoping there is a quick fix!

P.S I think it’s something with the HTML embeds and CMS data because I also made a change to some code for a third party plug (Likebtn) on a different page and I’m experiencing a similar issue.

The embed code uses an identifier class to get the unique value of each dynamic item to count the likes. It worked before but when I made the change and updated some of the other parts of the code, it no longer takes the unique value [Name]. It counts them all the same.

I also took the old code I had while it was working from a version restore but the issue to test if it was something I messed with from the original working code but the issue remains.

The code is within a span>

11 PM

I hate to pile on but I made a video use case that demonstrates how CMS items are not appearing when any minor change to the HTML embed is made. First I publish the website and show the items as they should appear, then I make a minor change to the code and re-publish and you can see none of the content from inside of the embed appears.

Hope this helps…

Thanks for sharing this extra information. I wasn’t able to reproduce any of the other issues described. It did look like there were some errors in the HTML of those embeds though — this may be the source of the issue.

We are still looking into the original issue reported and hope to have an update soon. That said, have you considered exporting these icons as SVGs and opting to use the image element rather than using the CMS to inject paths? Just curious as I think you can achieve the desired build without using the embed :slight_smile:

Hey Brando,

Did Webflow push a fix? Literally everything is working now!

Thanks for looking into this for me : )

1 Like

Hey Brando,

So I restored an earlier version to check some of my before body code and then restored to the version I was working on only to have the issue come back.

Is there issues with version restoring and HTML embeds? My code tests well on codepen and it was working before. Any idea what might be causing the embed code to not work properly?

The like button code was working after the apparent fix and before the restore, but now it is having the same issues. This suggests it isn’t my custom code causing the issues. Any ideas?

  • Kyle

Hi @moofawsaw

Thanks for the updates. Truthfully our team didn’t push any fixes for this particular issue (at least not specifically for this issue). That said, I’ve reopened the bug report and we can revisit the issue.

Can you send me a link to your codepen? I’d like to share this with the team to show there are no issues with your code.


Hey Brando,

Thanks for getting back to me. Here is the codepen exactly as it appears on my published page (less css styling):

Note that there are still issues with other embeds on different pages. I have tried removing the above code and re-publishing without any luck fixing the other embeds.

Thanks @moofawsaw

I shared this with the team as well and will update you when we have more information.

Hi @moofawsaw

Thanks again for reporting this and for your patience.

Our team pushed a fix for this issue — can you please refresh your designer, republish, and check to see if the issue has been resolved?

​Thanks in advance, and I’m standing by for your reply.

Beautiful! It’s working again. Do you mind sharing what was the issue and how it was resolved?

Thanks again for looking into this for me!

1 Like

@moofawsaw this was introduced in an update from a while ago which led to dynamic embeds not rendering properly on live sites. We were able to find the issue and pushed a fix to ensure dynamic embeds work as expected across all projects :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.